Support » Plugin: Brilliant Web-to-Lead for Salesforce » Error updating to PHP7

  • Resolved Barn2Media

    (@barn2media)


    Hi, I need to update my server to PHP7 and am getting an error, please could you provide a fix.

    The error is:

    FILE: /nas/content/live/agenthubltd/wp-content/plugins/salesforce-wordpress-to-lead/lib/salesforce_admin.class.php
    ——————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————
    13 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    ——————————————————————————————————————

    FILE: /nas/content/live/agenthubltd/wp-content/plugins/salesforce-wordpress-to-lead/lib/salesforce_widget.class.php
    ——————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————-
    4 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    ——————————————————————————————————————-

    FILE: /nas/content/live/agenthubltd/wp-content/plugins/salesforce-wordpress-to-lead/lib/yst_plugin_tools.php
    ————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————
    20 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    ————————————————————————————————————

    Many thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Nick Ciske

    (@nickciske)

    Version 2.7 (which was just released) should address this issue.

    Brilliant, thank you very much!

    Hi, I have updated to version 2.7 and am still getting the following errors:

    FILE: /nas/content/live/agenthubltd/wp-content/plugins/salesforce-wordpress-to-lead/lib/salesforce_admin.class.php
    ——————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————
    13 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    ——————————————————————————————————————

    FILE: /nas/content/live/agenthubltd/wp-content/plugins/salesforce-wordpress-to-lead/lib/salesforce_widget.class.php
    ——————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ——————————————————————————————————————-
    4 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    ——————————————————————————————————————-

    FILE: /nas/content/live/agenthubltd/wp-content/plugins/salesforce-wordpress-to-lead/lib/yst_plugin_tools.php
    ————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————
    20 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    ————————————————————————————————————

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error updating to PHP7’ is closed to new replies.