WordPress.org

Support

Support » How-To and Troubleshooting » Error updating anything through WordPress 2.7

Error updating anything through WordPress 2.7

  • xChristina80x
    Member

    @xchristina80x

    Hello!

    When trying to update anything through WordPress itself (like the plugins) I get the following error:

    Fatal error: Cannot unset string offsets in /public_html/wp-admin/includes/file.php on line 682

    Lines 680 – 684 are the following:

    if ( ! $error && !empty($credentials['password']) && !empty($credentials['username']) && !empty($credentials['hostname']) ) {
    		$stored_credentials = $credentials;
    		unset($stored_credentials['password'], $stored_credentials['private_key'], $stored_credentials['public_key']);
    		update_option('ftp_credentials', $stored_credentials);
    		return $credentials;

    Does anyone know how to fix this problem?

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Error updating anything through WordPress 2.7’ is closed to new replies.