Support » Installing WordPress » ERROR: Undefined index: PATH_INFO

  • Errors on my page. I get these messages:

    Notice: Undefined index: PATH_INFO in C:\Sites\Single38\mchwen\webroot\blog\wp-settings.php on line 72

    Notice: Undefined index: PATH_INFO in C:\Sites\Single38\mchwen\webroot\blog\wp-settings.php on line 75

    Warning: Cannot modify header information – headers already sent by (output started at C:\Sites\Single38\mchwen\webroot\blog\wp-settings.php:72) in C:\Sites\Single38\mchwen\webroot\blog\wp-login.php on line 202

    Warning: Cannot modify header information – headers already sent by (output started at C:\Sites\Single38\mchwen\webroot\blog\wp-settings.php:72) in C:\Sites\Single38\mchwen\webroot\blog\wp-login.php on line 214

    Warning: Cannot modify header information – headers already sent by (output started at C:\Sites\Single38\mchwen\webroot\blog\wp-settings.php:72) in C:\Sites\Single38\mchwen\webroot\blog\wp-includes\pluggable.php on line 552

    Warning: Cannot modify header information – headers already sent by (output started at C:\Sites\Single38\mchwen\webroot\blog\wp-settings.php:72) in C:\Sites\Single38\mchwen\webroot\blog\wp-includes\pluggable.php on line 685

    but when i tried to use the old wp-settings.php from 2.3 on 2.5, the site works without errors.

    What’s wrong? Help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same issue here. Everything’s working fine other than this error cropping up at the bottom of every page:

    PHP Notice: Undefined index: PATH_INFO in E:\Websites\migpilot_root\Bomb_Squad_Industries\Bomb_Squad_Industries\proto\wp-settings.php on line 72 PHP Notice: Undefined index: PATH_INFO in E:\Websites\migpilot_root\Bomb_Squad_Industries\Bomb_Squad_Industries\proto\wp-settings.php on line 75

    Ideas anyone?

    I get the same error, but when I put the old wp-settings file as you did mchwen, the following error appears:

    Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘do_shortcode’ was given in […]\wp-includes\plugin.php on line 163.’

    Does anyone know why the initial error came up for us?

    In reading some more forums, I found this

    http://wordpress.org/support/topic/164618?replies=5

    I am very much a newbie to php, but I blocked out the code suggested and my site works now. Hopefully it won’t cause further problems down the line…

    Hope it works for you too.

    Yep, did the trick. Looking at it I think this was an issue I had with an earlier version and the fix was the same. Thanks for that, did the trick just fine.

    Now back to testing it to make sure it works before rolling it out.

    I solve the problem inserting a simple check for PATH_INFO existence at the wp-settings.php.

    Just after the comment about IIS + PHP configuration (line 71) put this check:
    if ( isset($_SERVER['PATH_INFO']) ) {

    and close the if statement, just above the comment “// Append the query string if it exists and isn’t null”

    An alternative solution for Apache, is to set AcceptPathInfo=On inside httpd.conf

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘ERROR: Undefined index: PATH_INFO’ is closed to new replies.