Error: Unable to create directory uploads/2013/06. Is its parent directory writa (4 posts)

  1. piscesbec
    Posted 2 years ago #

    I've had my site running for years, with the same theme (updated) and never a problem. I am running my own domain name on a hosted server.

    I added a blank template page to the theme and was doing some testing and all was fine. Suddenly my entire theme vanished from the directory!

    I tried to upload the theme again, but keep getting the following message:
    Unable to create directory uploads/2013/06. Is its parent directory writable by the server?

    I did nothing at all on the server. I was working entirely from inside WordPress, so cannot understand why the permissions would have changed. I've never had an error like this before and I don't understand why a theme install is trying to create folders in the Uploads folder but I went and created the 2013 and 06 folders but the error persisted. I changed their permissions and the parent Uploads folder to 777 and still got the error.

    I tried a different theme but the error message still appears. I'm going crazy here. How can I get my theme back?

  2. Pioneer Web Design
    Posted 2 years ago #

    The theme can and will at time include header image for example that are in the uploads folder and also setup in the media library to work with theme customizer options...so my guess is that is what is hapeenning and the permissions are actually not set to give wp write permissions - contact your host on that issue...

    as for the page template causing your theme to disappear, that seems unusual - either the file was bad or somehow you deleted or removed the theme by accident.

  3. piscesbec
    Posted 2 years ago #

    I ended up unzipping my theme on my local machine, then uploading all the files via FTP while waiting for my hosting company to get back to me.

    The Linux Admin at my hosting company has now fixed the problem, by setting every folders relevant to any theme uploads to 777.

  4. tlgath
    Posted 2 years ago #

    I'm having the same issue. I host with BlueHost, and changed all the permissions on the folders to 777. But then, when I tried to edit my site, all I got was a blank page. After changing the permissions back to 755, I was able to edit again.

Topic Closed

This topic has been closed to new replies.

About this Topic