Support » Plugin: Wordfence Security - Firewall & Malware Scan » Error: Unable to accurately detect IPs

  • Resolved zztype


    All 105 of my Wordfence installs updated to 6.2.7 this morning. This afternoon, I’m starting to get email from many of those installs stating:

    This email was sent from your website “Linda Fong Studio” by the Wordfence plugin.

    Wordfence found the following new issues on “Linda Fong Studio”.

    Alert generated at Thursday 1st of December 2016 at 03:40:27 PM


    * Unable to accurately detect IPs

    So far, I have gotten this message from seven of my sites. I anticipate receiving more of them.

    Please advise.

Viewing 15 replies - 16 through 30 (of 66 total)
  • Ambyomoron


    Is this message generated if the probe occurs during a maintenance window, such as during the upgrade of a plugin? There is a clear correlation in my case, but I do not know if this is coincidence or a failure to account for this case in the logic of the plugin.

    This definitely popped up following the update to 6.2.7. I might be wrong, but I don’t think a minor update should cause the app to work significantly differently, so I really hope this is just a false positive, and wordfence keeps working as it should…

    Same here. It only seems to be affecting certain servers. Hopefully WF can patch this?

    I’ve just received the same alert for one of my sites this morning. Posting info incase it’s of any help:

    – Wordfence: 6.2.7
    – WordPress: 4.6.1
    – Standard shared hosting environment
    – Not using Cloudflare or similar services
    – “Sucuri Security – Auditing, Malware Scanner and Security Hardening” plugin installed alongside Wordfence, but no premium proxy/firewall enabled.

    Same here – I have just seen this from one site so far. Most of my sites are proxied via Cloudflare.

    However, I checked the live traffic logs and visitor IPs are showing up fine.

    In any case I went to Wordfence Options, and changed “How does Wordfence get IPs:” to “Use the Cloudflare ‘CF-Connecting-IP” HTTP header to get a visitor IP.” instead. I have the mod_cloudflare extension installed on Apache and as noted the visitor IPs are showing in the logs… but maybe there is something in the way that Wordfence does its scan that results in the error message?

    Anyway, if it is Cloudflare issue, then perhaps Wordfence needs to account for that, given the widespread usage of Cloudflare.

    Has any of you tried to run the scan again manually?
    Here tested two sites and second scan does not have this message again.

    Maybe this only happens once after the update and has no further concequenses?

    same problem (and reported by wordfence) on 2 wordpress sites with wordfence. wordfence that have updat5ed to current versions but wp system updates failed on 2 other sites a further 12 sites updated & have not yet presented the IP problem but BlogDesk is not able to upload to any of the sites. That suggests the problem may exist for all sites but not have been reported by wordfence



    Yes, I ran the scan manually and had no errors. Whether there is a one time error following upgrade, or some other cause, remains to be determined.

    Hi, on all websites (28) where I made the update I have this message, this on 6 different Web hosting.

    Same problem for me with 32 sites, running on several different hosts. Please patch.

    Hi there,

    The WordPress sites my company hosts that runs Wordfence are generating these errors. I’m not sure if this is a bug in Wordfence, or if it’s an issue on our end. If this is a bug, please patch.

    This is happening to all my sites too, about 40 customer sites and about 6 of my corporate accounts. Need to know what we need to do to fix it. Please let us know.

    Same here:

    Alert generated at Friday 2nd of December 2016 at 01:32:39 PM

    Warnings: * Unable to accurately detect IPs

    70 sites all hosted on a VPS Server.

    I have several sites with WordFence all on different servers that are all receiving this same error (Unable to accurately detect IPs). This all started after yesterdays update.

    I’m having the same problem. Some started reporting the problem yesterday and more today.

Viewing 15 replies - 16 through 30 (of 66 total)
  • The topic ‘Error: Unable to accurately detect IPs’ is closed to new replies.