Support » Plugin: Jetpack by WordPress.com » Error trying to connect site to facebook page

  • Resolved eyeswiseopen

    (@eyeswiseopen)


    Could not update the Publicize connections on the remote Jetpack site. No Publicize connection created.

    Any ideas why this is? or more importantly how to fix it

Viewing 15 replies - 1 through 15 (of 24 total)
  • new error
    500 status code for “POST /sites/158624671/publicize-connections/new”

    No connection regardless which SM platform
    Anything?

    Plugin Support lizkarkoski

    (@lizkarkoski)

    Hi –

    Please let us know which site you’re working on so we can take a closer look. Double check that you have enabled xml-rpc as well.

    Hi thanks for getting back on this

    Not sure how to check that xml-rpc is enabled? I understand it is enabled by default and I don’t believe it was disabled, but one lives and learn new things every day…
    The site is:
    https://agambooks.com

    Plugin Support Fotis

    (@fstat)

    Hi there,

    Please go to your site’s Dashboard > Jetpack > Settings > Sharing and make sure that Automatically share your posts to social networks under Publicize connections is enabled.

    I get the same error but on trying to connect to Facebook and Twitter:

    500 status code for “POST /sites/97420509/publicize-connections/new”

    Shall I open a new support topic?

    xml-rpc is enabled. Plugin ver 7.2.1

    • This reply was modified 6 months, 3 weeks ago by zimbo000.
    Plugin Support lizkarkoski

    (@lizkarkoski)

    @zimbo000

    Shall I open a new support topic?

    Yes, please. That’s the best way forward. Someone will be in touch as soon as possible. Be sure to let us know which site is involved as well.

    Please go to your site’s Dashboard > Jetpack > Settings > Sharing and make sure that Automatically share your posts to social networks under Publicize connections is enabled.

    It was always on!!!
    Still no joy

    works OK until the last stage and then get the message = Could not update the Publicize connections on the remote Jetpack site. No Publicize connection created.

    Plugin Support supernovia

    (@supernovia)

    @eyeswiseopen on your site I’m still seeing a debug error. Head to jetpack.com/debug, type in your address, and you’ll see the error there.

    I’m getting a 406 error, meaning your server is rejecting the xml-rpc request, even though xml-rpc is enabled.

    Can you show the error to your host?

    eyeswiseopen

    (@eyeswiseopen)

    I am sorry to say – the issue is not resolved yet
    I run Site Health and got

    ‘Jetpack.com detected an error. Jetpack
    Visit the Jetpack.com debugging page for more information or contact support.’

    following to the debugging page
    I got
    Communication error
    We were unable to make an XML-RPC request to your website. Please make sure that XML-RPC is turned on and that Jetpack is installed, activated and connected with your WordPress.com account.

    I then tried this

    ‘Check your XMLRPC file. You can do this by going to your website URL and adding “/xmlrpc.php” to the end (without the quotes). When it loads in your browser, you should see “XML-RPC server accepts POST requests only” on a line by itself.’

    And got the desired result
    “XML-RPC server accepts POST requests only” on a line by itself.

    What do I do next?

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    We’re being blocked from accessing https://agambooks.com/xmlrpc.php via cURL, which Jetpack requires to function.

    When we run:

    curl -A "Jetpack by WordPress.com" -is -H 'Content-Type: text/xml' --data '<?xml version="1.0"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'https://agambooks.com/xmlrpc.php' && echo

    We get:

    HTTP/2 401 
    cache-control: private, no-cache, no-store, must-revalidate, max-age=0
    pragma: no-cache
    content-type: text/html
    content-length: 624
    date: Tue, 21 May 2019 18:13:02 GMT
    server: LiteSpeed
    alt-svc: quic=":443"; ma=2592000; v="35,39,43,44"
    
    <!DOCTYPE html>
    <html style="height:100%">
    <head><title> 401 Unauthorized
    </title></head>

    Unfortunately, blocking XML-RPC is not a great solution for fighting security risks. It’s akin to selling your car because you don’t want it to be stolen.

    Your site’s XML-RPC file is kind of like a communication gateway to your site. Jetpack, the WordPress Mobile Apps, and other plugins and services will use this file to communicate to your site. If this is blocked, you will have other issues pop-up down the road for the same reasons.

    If you are using any security plugins, please try connecting with those temporarily deactivated. If you don’t have any, or if that didn’t work, I would suggest contacting your hosting provider and asking them to unblock your site’s XML-RPC. The most popular hosting providers out there have managed to find other ways to protect their servers without having to hinder your site and your ability to use services with your WordPress.

    eyeswiseopen

    (@eyeswiseopen)

    Hi
    thanks for explaining the role of XML-RPC
    1. There is nothing in the security plugin on that site that stops access to https://agambooks.com/xmlrpc.php.
    To be sure I moved them a way from the plugin folder and there was no change
    2. There is nothing on the server that block this file either.
    3. I run all the test suggested in your support docs and it seems OK.

    please help me sort it out

    Plugin Support KokkieH

    (@kokkieh)

    Have you contacted support at your hosting provider to ask about this? They may have security settings on the server that are not visible or accessible to you.

    Yes, the file at https://agambooks.com/xmlrpc.php appears to be fine. But when Jetpack tries to access that file via cURL, it returns an error that authorization is required, which indicates that at some level access is being blocked.

    There is nothing we can do from our end to fix this, as we don’t have control over which services can or cannot access your server.

    eyeswiseopen

    (@eyeswiseopen)

    Hi
    Thank you
    I have discussed it with the hosting provider
    And they have assured me there is nothing at their end that is blocking access to this file.

    Moreover I have other sites on the same server with no issues…

    However there is one thing that I just discovered that might have a bearing on this

    Wordfence new 2FA setting has introduced 2 new settings:

    Require 2FA for XML-RPC call authentication
    If enabled, XML-RPC calls that require authentication will also require a valid 2FA code to be appended to the password. You must choose the “Skipped” option if you use the WordPress app, the Jetpack plugin, or other services that require XML-RPC.

    Which I just turned off

    and

    Disable XML-RPC authentication
    If disabled, XML-RPC requests that attempt authentication will be rejected.

    Tried this both ticked on and off

    It made no difference
    The issue persists

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.