Support » Plugin: WooCommerce » Error: “There was an error getting your inbox.”

  • Resolved sebastian20

    (@sebastian20)


    Hi, I made a brand new wordpress installation with woocommerce and flatsome theme (all current versions). There are no other than the flatsome required plugins installed. At the woocommerce main admin page I get an error: “There was an error getting your inbox. Please try again.” How can I fix that?

Viewing 15 replies - 16 through 30 (of 36 total)
  • rigmcwebmaster

    (@rigmcwebmaster)

    I have this problem as well. No reason, WooCommerce status page is clean.

    I ran into this issue as well. For my situation, this ended up being caused by the security headers. Depending on your server environment you will need to validate your security headers ( in Apache2 this would be found in your .htaccess file )

    I’m not using Itheme and also getting this error: There was an error getting your inbox. Please try again.
    I hope there is another solution out there.

    Thank you @ac607. Your solution worked for me, too. I only had to uncheck “Filter Long URL Strings” under the “Long URL Strings” setting to make Orders and the inbox load on the WooCommerce home page.

    So, Happiness Engineers, now that you know that this is a thing, how about fixing it for all the people not lucky enough to find this thread?

    Charles

    (@charlesrodmell)

    Turning that security feature off isn’t really a solution is it. Nothing should be sending urls that long within wordpress.

    LuWi

    (@luwiserjeus)

    Thanks a lot @ac607, this definitely did the trick!

    Getting the same error, disabling HTTP HEADERS Plugin “Permissions Policy”, fixed.

    • This reply was modified 8 months, 3 weeks ago by faluas.

    No solution has worked for me yet.

    I confirm, I cannot find a solution to the problem.

    Same issue. WooCommerce main admin: *purple warning triangle* “There was an error getting your inbox. Please try again.”

    Not using iThemes. Brand new install, almost nothing on it – Jetpack; Limit Login Attempts Reloaded; Under Construction; and Woo Commerce / Payments / Shipping & Tax plugins.

    And I just tested. It’s not Limit Login Attempts or Under Construction. So that leaves Jetpack or Woo plugins – OR server-side stuffs/configs.

    I uninstalled Jetpack, still same problem

    Same issue here. Ithemes Security and Jetpack not installed.

    DarkCoder

    (@darkcod3r)

    i am also getting same issue… i am not using any ithemes security plugin.. @nicolamustone you going to solve this issue or just gonna pretend it is not WC related issue..?!

    Charles

    (@charlesrodmell)

    You aren’t missing out on anything. It’s just advertising for woocommerce extensions and stuff.

Viewing 15 replies - 16 through 30 (of 36 total)
  • You must be logged in to reply to this topic.