Support » Plugin: WooCommerce » Error: “There was an error getting your inbox.”

  • Resolved sebastian20

    (@sebastian20)


    Hi, I made a brand new wordpress installation with woocommerce and flatsome theme (all current versions). There are no other than the flatsome required plugins installed. At the woocommerce main admin page I get an error: “There was an error getting your inbox. Please try again.” How can I fix that?

Viewing 15 replies - 1 through 15 (of 33 total)
  • Plugin Support Nico

    (@nicolamustone)

    Automattic Happiness Engineer

    Hello there,
    The error message that you receive is not from WooCommerce. I have never seen it before, it might be from the theme or another plugin.

    Since you mention that only Flatsome plugins are installed, I recommend contacting their support and check with them.

    They should know better! I will mark this topic as Resolved since it is not relevant to WooCommerce.

    i have the same issue

    Same here using storefront.

    I managed to take a screenshot before the warning appears and it is trying to load an Inbox with subtitle “Insights and growth tips for your business”.

    In Woocommerce -> Home.

    acwporg

    (@acwporg)

    @nicolamustone maybe you should change your title to UN-happiness engineer.. what sort of diagnosis is that?

    I can confirm this error on Woocommerce Home page – /wp-admin/admin.php?page=wc-admin

    I can confirm the message only exists in Woocommerce source code..

    e.g. /wp-content/plugins/woocommerce/i18n/languages/woocommerce.pot
    /wp-content/plugins/woocommerce/packages/woocommerce-admin/languages/woocommerce-admin.pot
    /wp-content/plugins/woocommerce-admin/dist/chunks/10.5ad18ec555981926de5a.min.js
    /wp-content/plugins/woocommerce/packages/woocommerce-admin/dist/chunks/10.5ad18ec555981926de5a.js

    I can confirm the error occurs without any Flatsome plugins or themes.. never used them. Also not using Storefront.

    I did have the Woocommerce Admin plugin installed but deactivated previously due to other problems with it (can’t recall now). I’ve even completely deleted the plugin now and that error is still occurring.

    Maybe you can un-resolve it now and investigate properly.

    PS – Javascript console is getting a 414 error on this URL
    https://<domain>/wp-json/wc-analytics/admin/notes?page=1&per_page=25&status=unactioned&orderby=date&order=desc&_fields%5B0%5D=id&_fields%5B1%5D=name&_fields%5B2%5D=title&_fields%5B3%5D=content&_fields%5B4%5D=type&_fields%5B5%5D=status&_fields%5B6%5D=actions&_fields%5B7%5D=date_created&_fields%5B8%5D=date_created_gmt&_fields%5B9%5D=layout&_fields%5B10%5D=image&_fields%5B11%5D=is_deleted&_locale=user

    So this URL without parameters aka /wp-json/wc-analytics/admin/notes returns this:
    {
    “code”: “woocommerce_rest_cannot_view”,
    “message”: “Sorry, you cannot list resources.”,
    “data”: {
    “status”: 401
    }
    }

    • This reply was modified 9 months ago by acwporg.
    • This reply was modified 9 months ago by acwporg.
    • This reply was modified 9 months ago by acwporg.
    Gerry2014

    (@gerry2014)

    I too am getting this error in Woocommerce on every site I set up now. It must be a common problem.

    “There was an error getting your inbox. Please try again.”

    Does anybody have any ideas?

    andiwest

    (@andiwest)

    I have this problem as well. @nicolamustone, are you going to reopen this issue or do I have start a new thread.

    ps. Unless you are the US government, you can’t simply deny responsibility, declare victory, and run from the problem.

    ac607

    (@ac607)

    Hi all,

    I had the same problem and noticed that you did too. Not sure if this helps ( as I’m not an expert) but after doing some research I found that the issue was to do with my security configuration.

    I use iTheme security for all my websites and had found that it was simply a setting that that needed to be unticked. Under the system settings (iThemes settings), go to “Filter Long URL Strings” and UNTICK the box. When ticked, it limits the number of characters that cane be sent in the URL.

    This option worked for me therefore maybe it might work for you. It also maybe another option on another security plugin.

    Additionally, I also had a message that stated, “There was an error getting your inbox. Please try again.” as well as, “There was an error getting your stats. Please try again.” This could probably cause some confusion, as it did for me but I assume that the issue covered both due to the long URL string.

    Hope the above helps and if not, hope you solve the problem!

    • This reply was modified 9 months ago by ac607.

    Yes, @ac607 solution is correct.

    Had the same issue and ac607 has the correct solution for me too. thanks!

    As ac607 says – also got the same on a bunch of sites – go to Ithemes, Security, System Tweaks and uncheck filter long urls.

    Thank you @ac607. This was the answer for me too. @nicolamustone this is definitely an issue with Woocommerce. I suggest you re-open this. Thank you.

    jmsalanova

    (@jmsalanova)

    Gracias @ac607 Solucionado el problema, era el filtrado de cadenas de iThemes, con el permiso de @nicolamustone claro.

    Thanks to ac607 (@ac607) for posting that solution. Ithemes security caused that issue for me.

    I had the same issue. For those running iThemes Security, the ‘solution’ is to disable these two System Tweaks options:

    • Filter Suspicious Query Strings in the URL
    • Filter Long URL Strings

    I have the same issue.

Viewing 15 replies - 1 through 15 (of 33 total)
  • You must be logged in to reply to this topic.