Support » Plugin: WP Cerber Security, Anti-spam & Malware Scan » ERROR: The plugin is initialized in a different mode that does not match the set

  • Hi,

    We have some issues with the plugin and the addon for Cloudflare. We are using WP Cerber for years and it works perfectly, but yesterday we installed the addon for the Cloudflare integration so we can increase our security, and after that, we are facing some error that we don’t know why it’s appearing:

    ERROR: The plugin is initialized in a different mode that does not match the settings. Check the "Load security engine" setting.

    Before this, I must say that we followed your tutorial for installing the Cloudflare addon, including the switch of Load security engine to Standard mode which worked for a couple of hours and after that, it went back automatically to the Legacy mode and we cannot switch again to Standard mode.

    We have checked the diagnostic tab, but everything is writable except for WP Cerber’s quarantine folder which it’s fine because this folder is created automatically. Also, we have deactivated and deleted the Cloudflare addon, but we are still facing the same issue.

    Any solution?

    Kind Regards,
    Martin

    • This topic was modified 7 months, 2 weeks ago by sancukosan.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Gregory

    (@gioni)

    Hi! The issue has nothing to do with the Cloudflare addon. Please check “WordPress must use plugin folder” on the Diagnostic tab. You should see it as “Writable 0755”.

    Thread Starter sancukosan

    (@sancukosan)

    Hi Gregory,

    Thanks for coming back. As I have mentioned above, everything is writable on the Diagnostic tab, even the Must use plugin folder which is set as “Writable 0777”.

    Anyway, this never happened in years of using this plugin, but since we have activated the Cloudflare addon, which as you said may not be related to this error, but I’m just trying to explain to you that we did not have this problem before.

    Kind Regards,
    Martin

    • This reply was modified 7 months, 2 weeks ago by sancukosan.
    Plugin Author Gregory

    (@gioni)

    Can you enable the Standard mode again? Does it work? It’s possible that you get the issue due to a web server glitch.

    Thread Starter sancukosan

    (@sancukosan)

    Hi Gregory,

    We are still facing this issue. As I said before, We are not able to switch over Standard mode after activating the Cloudflare addon. The issue is still there after disabling and deleting this Cloudflare addon.

    Solution?

    Plugin Author Gregory

    (@gioni)

    Try to save the settings with “Standard mode” enabled and check the server error log right away.

    Thread Starter sancukosan

    (@sancukosan)

    Hi Gregory,

    No other errors, but only this one which I think it’s not related to my issue:

    [substitute:error] [pid 8724:tid 1200] [client 46.217.165.229:60646] AH01328: Line too long, URI /wp-admin/admin-ajax.php, referer: /wp-admin/network/admin.php?page=cerber-integrity

    Kind Regards,
    Martin

    Thread Starter sancukosan

    (@sancukosan)

    Hi Gregory,

    Did you have a chance to look into this and tell me what is the best solution here?

    Kind Regards,
    Martin

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘ERROR: The plugin is initialized in a different mode that does not match the set’ is closed to new replies.