Support » Fixing WordPress » Error text after creating wp-config.php: “p-settings.php’); ?>”

  • I have been having blank page problems after updating my k2 theme. I’ve tried nearly everything and nothing works: the home page and wp-admin pages are still all blank.

    Just now, I was toying with renaming the wp-config.php file, and went through the process of creating a new file through a browswer after renaming it. After filling in the info, I hit install now, and got this text:

    p-settings.php’); ?>

    Now I fear my blog is really screwed.

    See here:

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • so just re-upload the files you screwed with.

    The wp-config.php file points to your database. If that info is incorrect, WP won’t be able to find your blog contents. And BTW, you aren’t upgrading a THEME, you are upgrading your BLOG (specifically, the database). I hope you kept a copy of that wp-config.php file. Otherwise, you’ll just have to reenter your database information. When WP throws out blank pages after an upgrade or install, that’s usually the result of file corruption upon upload (FTP usually).

    I’ve posted about this numerous times here and in fact, step by step procedures (which including deleting certain files from your server before performing the upgrade) can also be found here.

    Gotta love him. He said in one sentence (eight words and 10 syllables) what it took me all that to say. 😛

    [What happened was that I got up in the middle of writing the post and got a cup of coffee and chatted up the girl down the hall. I came back here and finished the post. Meanwhile Mr. Succinctly Brutal had already been by to answer the question.]

    Muahaha <3

    Ok, I re-uploaded the old wp-config.php file. I’m back to looking at blank pages. The deal is that I really want some kind of resolution to this blank page syndrome, which started my I tried updating my k2 theme (by overwriting the older files via FTP.) Since then, I have been staring at blank pages, and nothing I’ve done (including re-uploading k2 again and again, both old and new, or deleting my plugins, etc.), has done anything.


    I’ve repeated and repeated and repeated this until I am blue in the face. I stated it above, BUT YOU IGNORED IT!!!!

    DELETE the old files, do not overwrite them. Just nuke the K2 theme folder (isn’t it called Default?). And ditto the other WP files for upgrading:

    Delete everything in these folders:

    Delete all *.php files in the root WP install except wp-config.php

    DO NOT delete your robots.txt or .htaccess files if you have them.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error text after creating wp-config.php: “p-settings.php’); ?>”’ is closed to new replies.