WordPress.org

Support

Support » Installation » [Resolved] ERROR: "Table Prefix" must not be empty

[Resolved] ERROR: "Table Prefix" must not be empty

  • Baker

    @thereachchurch

    I have had WP installed and running for months. Today I had a problem with file uploads, and after many attempts, I decided to reinstall and see if I could start from scratch.

    I went to set up the config using setup-config.php, and filled in ALL of the information. However when I continue to the second step, it gives me this error–

    ERROR: “Table Prefix” must not be empty

    I deleted all of 3.5 and also tried with 3.4.2 and still have the same problem.

    I tried doing the config.php manually using wp-config-sample.php and filling out my info, but that gave me a database connection error.

    My site is http://www.thereachchurch.com

Viewing 2 replies - 1 through 2 (of 2 total)
  • Baker

    @thereachchurch

    Ok, after taking a break I was able to manually create the wp-config again using the sample, this time I scrolled all the way down and filled in the keys. That worked just fine.

    I am now able to get into install.php, but even though I fill in the email address correctly, it says

    ERROR: you must provide an e-mail address.

    I notice both the email and the table prefix fields are the last form fields on their forms (aside from a privacy checkbox). I don’t know if that means anything but I’m very frustrated. Some help would be greatly appreciated.

    —————-

    After reading this: http://perishablepress.com/important-security-fix-for-wordpress/ I have moved my install.php so I don’t get hacked.

    Baker

    @thereachchurch

    Ok, I figured it out.

    I had, in my previous installation, created a php.ini file to raise my upload size limit using these lines:

    upload_max_filesize = 32MB
    post_max_size = 32MB

    I found this thread: http://wordpress.org/support/topic/error-you-must-provide-an-e-mail-address-3?replies=4

    where the OP deleted those lines and was able to solve the problem.

    Now I’m stuck with figuring out how to get the larger size limits without those lines? But at least we’re back in business.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] ERROR: "Table Prefix" must not be empty’ is closed to new replies.
Skip to toolbar