Support » Plugin: Advanced Custom Fields » Error "Strict Standards" on all pages of WordPress backend

  • Resolved Ov3rfly

    (@ov3rfly)


    After a fresh install with WordPress 3.6 and ACF 4.1.8.1 and WP_DEBUG set to true, I started to see this php message on every page of WordPress backend:

    Strict Standards: Declaration of acf_taxonomy_field_walker::start_el() should be compatible with Walker::start_el(&$output, $object, $depth = 0, $args = Array, $current_object_id = 0) in ../wp-content/plugins/advanced-custom-fields/core/fields/taxonomy.php on line 471

    Edit: Took a closer look now and the error disappears if in file taxonomy.php line 408

    function start_el( &$output, $term, $depth, $args = array(), $current_object_id = 0)

    is changed to

    function start_el( &$output, $term, $depth = 0, $args = array(), $current_object_id = 0)

    Edit 2: There are more Strict Standards error messages caused by e.g. field_group.php or _functions.php when the fields are displayed on a page or post edit page in backend, please publish a fixed version, thanks.
    http://wordpress.org/plugins/advanced-custom-fields/

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Error "Strict Standards" on all pages of WordPress backend’ is closed to new replies.