Support » Plugin: WC Product Bundles » error Strict Standards Declaration of WC_Product_Bundle

  • After update WooCommerce to 3.0 I have errors. What to do?

    Strict Standards: Declaration of WC_Product_Bundle::get_price() should be compatible with WC_Product::get_price($context = ‘view’) in /home/qid00079/domains/website-name.com/public_html/wp-content/plugins/woocommerce-product-bundles/includes/class-wc-product-bundle.php on line 2038

    Strict Standards: Declaration of WC_Product_Bundle::get_regular_price() should be compatible with WC_Product::get_regular_price($context = ‘view’) in /home/qid00079/domains/website-name.com/public_html/wp-content/plugins/woocommerce-product-bundles/includes/class-wc-product-bundle.php on line 2038

    Strict Standards: Declaration of WC_Product_Bundle::get_sale_price() should be compatible with WC_Product::get_sale_price($context = ‘view’) in /home/qid00079/domains/website-name.com/public_html/wp-content/plugins/woocommerce-product-bundles/includes/class-wc-product-bundle.php on line 2038

    Strict Standards: Declaration of WC_Product_Bundle::is_on_sale() should be compatible with WC_Product::is_on_sale($context = ‘view’) in /home/qid00079/domains/website-name.com/public_html/wp-content/plugins/woocommerce-product-bundles/includes/class-wc-product-bundle.php on line 2038

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the same issue after the Woocommerce update.

    Product_Wcpb::get_price() should be compatible with WC_Product::get_price($context = ‘view’) in /home2/teacrown/public_html/wp-content/plugins/wc-product-bundles/classes/wc_bundled_product.php on line 117

    Warning: Declaration of WC_Product_Wcpb::get_regular_price() should be compatible with WC_Product::get_regular_price($context = ‘view’) in /home2/teacrown/public_html/wp-content/plugins/wc-product-bundles/classes/wc_bundled_product.php on line 117

    Warning: Declaration of WC_Product_Wcpb::get_sale_price() should be compatible with WC_Product::get_sale_price($context = ‘view’) in /home2/teacrown/public_html/wp-content/plugins/wc-product-bundles/classes/wc_bundled_product.php on line 117

    Warning: Declaration of WC_Product_Wcpb::get_weight() should be compatible with WC_Product::get_weight($context = ‘view’) in /home2/teacrown/public_html/wp-content/plugins/wc-product-bundles/classes/wc_bundled_product.php on line 117

    How can this be fixed?

    Thank you!

    Same error here. Looks like no one from WooCommerce monitors this space

    Hey,

    Same error here.

    Can the plugin developer Saravana Kumar please check the plugin and see if you can fix the warning?

    Otherwise great and easy to use plugin.

    Thank you

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘error Strict Standards Declaration of WC_Product_Bundle’ is closed to new replies.