Support » Plugin: WordPress Infinite Scroll - Ajax Load More » Error started in adminajax

  • Hi there,

    As of last night I am getting this error in my console

    Error: TypeError: Cannot read property ‘postcount’ of undefined
    at Object.n.AjaxLoadMore.success (ajax-load-more.min.js?ver=5.4.3:6)
    at ajax-load-more.min.js?ver=5.4.3:6

    Happened randomly as far as I can tell.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author dcooney

    (@dcooney)

    Ive seen this happen when a Repeater Template may have some issues.
    In the next ALM release this will not be a blocking issue as I plan to have this silently fail.

    Can you share the Repeater Template?

    Thread Starter rideorcry

    (@rideorcry)

    sure thing

    <div class="story">
                <a href="<?php the_permalink(); ?>">
                    <?php $url = wp_get_attachment_url( get_post_thumbnail_id($post->ID) );
    echo '<div class="thumb-image" style="background-image: url('. $url.')"></div>'; ?>
                </a>
    
                <div class="story-info">
    
                    <?php get_template_part( 'template-parts/content', 'categories' ); ?>
    
                    <a href="<?php the_permalink(); ?>">
                        <h3>
                            <?php the_title(); ?>
                        </h3>
                    </a>
                    <p>
                        <?php the_excerpt();?>
                    </p>
                    <h5>
                        <?php the_author(); ?>
                    </h5>
                </div>
            </div>
    Plugin Author dcooney

    (@dcooney)

    Hmm looks fine.
    I would start by debugging this template.
    Maybe remove everything except for <h3><?php the_title(); ?></h3>

    Thread Starter rideorcry

    (@rideorcry)

    So weird, i just made a duplicate copy of the theme and initiated then it started working again?

    I folowed the steps on this page and even ran with just the title like stated above and still didn’t work. Getting the following:

    ajax-load-more.min.js?ver=5.4.3:6 Error:  Error: Network Error
        at t.exports (ajax-load-more.min.js?ver=5.4.3:6)
        at XMLHttpRequest.p.onerror (ajax-load-more.min.js?ver=5.4.3:6)
    ajax-load-more.min.js?ver=5.4.3:6 XMLHttpRequest {readyState: 4, timeout: 0, withCredentials: false, upload: XMLHttpRequestUpload, onreadystatechange: ƒ, …}
    ajax-load-more.min.js?ver=5.4.3:6 ALM Error started in adminajax
    ajax-load-more.min.js?ver=5.4.3:6 ALM Error Debug:  
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.