Support » Plugin: Link Library » Error: Sorry, you are not allowed to access this page.

  • Resolved ahau

    (@ahau)


    I have been using Version 5.9.15.7 as I have never been able to get a newer version to work but thought I should try again. After taking a BU of the files and DB I went and updated.

    On the pages, all of the links have disappeared – but the text that is not the links is still there.

    I then went to the admin page (../wp-admin/admin.php?page=link-library) and got the error message Sorry, you are not allowed to access this page.

    I then re-installed the old version and it works again.

    It I exported all of the links from the old version and uninstalled it, then installed the latest version could I import all of the links from the export and retain all of the categories from that?

    Or would I have to manually set all of the categories again?

    I know I have to get the latest version working.

    Thank you for your time.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Yannick Lefebvre

    (@jackdewey)

    Sorry for the trouble.

    After you update to version 6.x, the admin page will no longer be in the same place. Instead of ../wp-admin/admin.php?page=link-library, the top of the Link Library menu will be at: ../wp-admin/edit.php?post_type=link_library_links. The library configuration page is at: ../wp-admin/edit.php?post_type=link_library_links&page=link-library-settingssets

    If you are not seeing any links after the update, you should just have to do to the Global Options page of Link Library (../wp-admin/edit.php?post_type=link_library_links&page=link-library-general-options) and click on the button labeled “Reset current library”. This will do a pass at repairing the link data and making sure that you are able to use the latest version.

    If that still does not work, you could indeed export and re-import links, but just pushing that button in the new admin should do the trick.

    Let me know how this goes and please consider donating to support this plugin’s development.

    Thank you for your reply. I updated again, followed your instructions above and the links did update, but not display.

    Hunting around I found it was because of old shortcodes, so I tried to update the shortcodes but could not get it to work as I want.

    I have 7 libraries so took this code from the library settings page for one library
    [link-library settings=7] and put in a post to update it and got
    All of your links must be assigned at least to one category to be displayed

    I then found the ID for the category I was testing and used [link-library settings=260] and all of the categories and links displayed

    By using just [link-library] I get
    All of your links must be assigned at least to one category to be displayed

    By using just [link-library-cats] I get
    No categories found.

    I need it to work so that each library will only show links for that library category. So in the meantime I have re installed my old version, but if you could give me the shortcode I need for it to work, that would be great 😀

    Thank you for your time 🙂

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    In the fourth paragraph, you mention using the shortcode [link-library settings=260]. Is that accurate? I doubt that you actually have 260 library configurations. Sounds like you only have 7 from earlier in your e-mail.

    That being, if [link-library settings=260] worked, it basically means that categories are not selected properly in the 7 library configurations that you brought over. For some reason, the category IDs in each library configuration did not get convert as it should have.

    So after updating to latest version, if you go into each library configuration under the common tab, you should be able to update the list of categories to be included, then see all categories. The same applies to the [link-library-cats] shortcode. It refers to the list of categories set in library configuration 1. If that is incorrect, it can’t display anything.

    If you are not sure what do to under the Common tab of library configuration, send me a screenshot and I can confirm what to do.

    Perfect – as soon as I found checked the library to see that the cats were in them I found they were not, so once I sorted that, it works perfectly – I did not even have to change my code on the pages so very very happy 🙂

    I re-checked the Cat ID and did find those high numbers – may be because I did try a few times with Cats when I first installed this (then deleted alot and added more, so that may be why the numbers are high.

    Also, when I first installed this I was changing a 20 year old site to WP so had some interesting data that I could not fit into any other plugin. I did find your cookbook, so bought it and have made a custom plugin for my site that uses that data 😀

    So, thank you for a great plugin, the help to get it to work, and the excellent cookbook – it is very much appreciated 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.