Support » Plugin: Simple Giveaways » ERROR: Sorry, there was an error….

  • Resolved bjrnet21

    (@bjrnet21)


    Just installed the plug-in this morning but unable to get it to work past one entry.

    It seemed to work when I entered my email address using Firefox. I got the email verification.

    Now, in a separate browser (Chrome and Bing) I attempted to enter a different email address but I got the following message:

    ERROR: Sorry, there was an error. Please be sure JavaScript and Cookies are enabled in your browser and try again.

    Of course, JavaScript and Cookies and enabled in all my browsers.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • bjrnet21

    (@bjrnet21)

    Also, I don’t understand the link under ENTER which has FORGOT YOUR SUBSCRIBED LINK?

    I have spent an hour looking at settings but unable to fix this. This plug-in is broken on my site and I guess I will have to look elsewhere for a compatible product.

    Plugin Author Igor Benic

    (@ibenic)

    Hi @bjrnet21,

    sorry for a late response. This seems like a compatibility issue with another plugin as such errors are not returned by this plugin.

    I would assume that the errors might be due to a Security plugin or similar. Could you give me a list of all plugins you’re using? That could help me so I can install them and check if the error persists. Are you using the wp-spamshield maybe?

    As for the “Forgot your subscribed link”: each subscriber that enters your giveaway will have a unique link. That way, even if the subscriber clears his/hers cookies and don’t have the first email, they can get the subscribed link sent again to their email.

    • This reply was modified 1 month, 4 weeks ago by Igor Benic.

    Thank you for the response. I think I understand the SUBSCRIBED LINK thing now.

    I do use a LOT of plugins. Probably more than I should but everything works.

    I did a search for “Sorry, there was an error” in all my plugins and wp-spamshield.php comes up. Looks like that is where the message comes from.

    I checked the settings for SpamShield. I tried checking (enabling) the following:
    “Disable anti-spam for miscellaneous forms”

    That appeared to have done the trick.

    Thank you for your help.

    Plugin Author Igor Benic

    (@ibenic)

    Hi @bjrnet21,

    I’ll check the SpamShield to see if I can somehow write a code that will prevent it to show such error so you can still have that option enabled for other forms/plugins.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.