• Resolved mcidesarrollo

    (@mcidesarrollo)


    Hello, I have a problem with a sitemap because of the cache. It gives me error in Search Console only in Woocommerce product sub-sitemaps: https://goyasonido.com/sitemap_index.xml/

    Sitemaps that are not product pages load them well.
    Previously all sub-sitemaps were loading well in Search Console.

    The error that Search Console gives is:
    – The sitemap is readable, but has errors
    – We have not been able to read your sitemap. It may contain an entry that we cannot recognize. Validate the sitemap before sending it again.
    – Examples: Line 1

    I am generating the sitemap with Yoast SEO and it is accessible through the browser but Search Console does not index any of its product pages.

    I have all these rules written in Hummingbird / Page Caching / exclusions:
    wp-.*\.php
    index\.php
    xmlrpc\.php
    sitemap.xml
    .*-sitemap.xml
    sitemap_index.xml
    \/sitemap_index.xml
    \/*sitemap.xml
    https:\/\/goyasonido.com\/cesta*
    https:\/\/goyasonido.com\/cesta\/
    sitemap.xml
    sitemap_index.xml
    .*-sitemap.xml
    post-sitemap.xml
    page-sitemap.xml
    category-sitemap.xml
    product-sitemap.xml
    product-sitemap1.xml
    product-sitemap2.xml
    product-sitemap3.xml
    product-sitemap4.xml
    product-sitemap5.xml
    product-sitemap6.xml
    product-sitemap7.xml
    product-sitemap8.xml
    product-sitemap9.xml
    product_cat-sitemap.xml
    pa_marca-sitemap.xml
    \/post-sitemap.xml
    \/page-sitemap.xml
    \/category-sitemap.xml
    \/product-sitemap.xml
    \/product-sitemap1.xml
    \/product-sitemap2.xml
    \/product-sitemap3.xml
    \/product-sitemap4.xml
    \/product-sitemap5.xml
    \/product-sitemap6.xml
    \/product-sitemap7.xml
    \/product-sitemap8.xml
    \/product-sitemap9.xml
    \/product_cat-sitemap.xml
    \/pa_marca-sitemap.xml

    If I type “product-sitemap1\.xml” Yoast SEO removes “\” when saving getting “product-sitemap1.xml”.

    I have cleared the cache and regenerated the permalinks. I have also removed the sitemap in Search Console and resubmitted it but errors still appear.

    Do you know what the problem may be?

    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @mcidesarrollo

    I checked some sitemap files and couldn’t see them as cached.

    The following exclusion rules should do the trick for all sitemaps though:

    sitemap_index.xml
    .*sitemap*.xml

    Can you update your settings and check again?
    Let me know how that goes.

    Thank you,
    Dimitris

    Thread Starter mcidesarrollo

    (@mcidesarrollo)

    I have deactivated Hummingbird and for the moment the first 2 Woocommerce sitemaps with 1000 products each appear correct.
    I’m going to wait a few days to see if google is correcting the other sitemaps. Then I will activate Hummingbird again and try the exclusions that you indicate.

    Thank you very much!

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @mcidesarrollo

    Thanks for response and giving it a try. Keep us updated, please!

    Best regards,
    Adam

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error sitemap in Search Console’ is closed to new replies.