Support » Plugin: Jetpack by » Error: site_inaccessible. Can't connect with

  • Resolved gscohier



    Not sure if anyone can help.
    I’m also having an issue. Never been able to get Jetpack to work.
    Getting the following error: site_inaccessible

    Error Details: The Jetpack server was unable to communicate with your site [IXR -32300: transport error: http_request_failed Operation timed out after 15273 milliseconds with 0 out of -1 bytes received]

    Spoken to GoDaddy and they’re telling me it’s not their problem and they can’t help.

    Looking at the Jetpack troubleshooter, I then asked GoDaddy to change the PHP_FCGI_CHILDREN to 2 as asked by Jetpack but I’m being told don’t know what I’m talking about and that that file is in WordPress. When I google this, it says it’s not a WordPress file but one held by the hosting company.

    I’ve tried uninstalling Jetpack and reinstalling it but no joy there…
    I have the updated versions of both WordPress and Jetpack installed.
    I’ve also tried unable all plugins and using the 2012 theme but didn’t make any difference.

    Help anyone? I’m going around in circles!

    Site is:

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Contributor Richard Archambault


    It looks like you are on a Windows server. As you mentioned, the fix to your issue is normally to change the PHP_FCGI_CHILDREN to 2. If GoDaddy doesn’t want to do that, try asking them to move your account over to a Linux server instead, it might work better by default without having to play with PHP_FCGI_CHILDREN. Let me know what they tell you.

    There are some limitations with PHP and Windows. We do recommend that you are on a Linux server at this time for running WordPress, PHP, based sites. Support can help get you to Linux no worries, but here is the guide to so online too: Please let us know if changing resolves the issue. Thanks! ^Colby GoDaddy Social Media Team

    I have an error too with Windows server. However, it used to work in the past as I succesfully connected my LinkedIn profile through Publicize.
    Now, nothing works.
    Will try to contact GoDaddy support.

    Update: nope. My hosting plan is the free basic one that comes with the domain. I can’t change it to Linux. I have to abandon the plugin now until you guys figure out how to make it work again with Windows server.

    It worked before. There shouldn’t be any reason why it can’t work again.

    Shame on you, GoDaddy.



    I’m afraid I can’t change to Linux since I have SSL.

    As per the link given above: “You cannot switch the operating system of a hosting account with a secure socket layer (SSL) installed on it.”

    Plugin Contributor Richard Archambault


    gscohier, we’re working on finding a fix for the limitations that GoDaddy seems to be putting on it’s Windows servers at the moment, which are affecting many of our Jetpack users in the same way. If you can’t switch, can you ask GoDaddy if they are otherwise limiting the number of PHP processes for your site?

    Hi Richard,

    I tried the PHP route with them but was told this was a WordPress file which is of course incorrect.
    I’ve since been told the following in an email: “Jetpack 2.3 which we install by default with all WordPress installations does not work with PHP 5.3, and requires PHP 5.2. You will need to upgrade Jetpack to 2.3.1 so that it will work with PHP 5.3.”

    I have the latest Jetpack installed but I’m still getting the same error message.

    When bringing up the Jetpack issue with GoDaddy, I was told the following, I quote: “We have leased you a flat, it’s not our fault if the hot tub installed in that flat isn’t working”…
    I’m not quite sure what anyone would respond to that….

    Plugin Contributor Richard Archambault


    Hi gscohier,

    You are currently running Jetpack 2.3.3 : so their suggestion doesn’t make any sense.

    As for not being compatible with PHP 5.3, that just isn’t true. As I mentioned, we think that there’s something about their Windows / PHP configurations, as you are not the only one to have this issue.

    Have you considered other hosts that could set you up on a Linux server?

    Hi Richard,

    I can migrate to the Linux servers.
    I’m all really new to this and when purchasing the package, I was given the choice between Linux and Windows.
    I stupidly assumed that this related to my operating system so I chose Windows… Bet I’m not the first and won’t be the last…

    Anyhow, I’m now dealing with emails back and forth since I’m given conflicting information by their support staff. Every email is picked up by someone different…

    One minute, I’m being told I can’t migrate without canceling the SSL certificate then the next email, I’m told I can by someone else.
    I’m trying to clarify things a bit before I press the button…
    I’ve only just purchased the hosting package and don’t really want to have to pay for a new SSL certificate less than a month on…

    Plugin Contributor Richard Archambault



    I just want to say that you weren’t stupid, it’s a common error for people who are new to the world of webhosting, but now you’re learning!

    Would you mind telling me why you need an SSL certificate? You don’t have anything on your site (shopping carts or similar things) that normally would need one as far as I can see, but it’s worth noting that pretty much every link I’ve tried on your site gives a 404 error, so it looks like you have other problems than just connecting Jetpack at the moment. It almost seems like it wouldn’t be a big issue to simply start over with hosting somewhere else, if you were so inclined, if your site isn’t working properly.

    Hi Richard,

    There will be some e-commerce attached for some services.

    Since I was encountering a number of issues, I decided to migrate last night to the Linux servers.
    Turns out despite being told that I wouldn’t notice a thing and everything would work just fine, the only pages which work ae the home pages…
    Godaddy is looking into it.

    On the plus side, I’ve activated both Jetpacks whithin seconds… πŸ™‚

    Plugin Contributor Richard Archambault


    Well, I’m glad you were able to switch, but I’m sorry about the other troubles! I hope things work out for you soon, and if you need further Jetpack help, you know where to turn. πŸ™‚


    Everything on the site looks good now. It sounds like you have everything worked out, but if there are any lingering problems or issues, please comment here. We’ll do our best to help and I am following this thread as well.


    Hello Godaddy! I am also having the same issue. I want to shift my hosting to linux. Can you people shift it for free or should I pay you? And help me how to shift the plan?

    I blog at:

    Plugin Contributor Richard Archambault


    Hi mothivenkatesh,

    To switch your site to Linux, go to your site management panel, and try the following:

    1) Click the + next to the hosting
    2) Clicked on options, then the customize tab
    3) Select the drop down menu under β€œPlan” and scroll up to select Linux

    According to GoDaddy, it can take up to 48 hours for the changes to apply, but your site will be completely transferred, and you will then be able to use Jetpack.

    If you do not feel comfortable making the change by yourself, do not hesitate to contact GoDaddy directly to let them know about the issue.

    Thanks for jumping in there with those instructions! You’re awesome!

    You can also view those instructions on our site here:

    And if you do get stuck, like Richard mentioned, Support is 24/7 and will be more than happy to walk you through the process if you give them a call. There’s no charge for this change or for support:


Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Error: site_inaccessible. Can't connect with’ is closed to new replies.