WordPress.org

Forums

WP Mail SMTP
Error since Update in wp-mail-smtp/wp_mail_smtp.php on line 109 (13 posts)

  1. Christian M. Grube
    Member
    Posted 1 year ago #

    Hi,

    updated to the new Version today on WordPress 3.7.1 and the backend do not work anymore.
    We have:
    Fatal error: Call-time pass-by-reference has been removed; If you would like to pass argument by reference, modify the declaration of apply_filters(). in /MYSERVERPATH/wordpress/wp-content/plugins/wp-mail-smtp/wp_mail_smtp.php on line 109

    Greetings

    http://wordpress.org/plugins/wp-mail-smtp/

  2. rodbauer
    Member
    Posted 1 year ago #

    Also got the same fatal error with WP 3.7.1 when I updated to new WP Mail SMTP this morning.

  3. Christian M. Grube
    Member
    Posted 1 year ago #

    Deleted the new one and use the old one
    http://downloads.wordpress.org/plugin/wp-mail-smtp.0.9.1.zip
    Hope a Update will be there soon

  4. utnalove
    Member
    Posted 1 year ago #

    Me too, got the same: Call-time pass-by-reference has been removed; If you would like to pass argument by reference, modify the declaration of apply_filters()

  5. burun0
    Member
    Posted 1 year ago #

    Same problem here.

  6. Olaf Lederer
    Member
    Posted 1 year ago #

    Same error here:
    Fatal error: Call-time pass-by-reference has been removed; If you would like to pass argument by reference, modify the declaration of apply_filters(). in /home/user/public_html/wp-content/plugins/wp-mail-smtp/wp_mail_smtp.php on line 109

  7. Surbma
    Member
    Posted 1 year ago #

    +1 :(

  8. KProvance
    Member
    Posted 1 year ago #

    If you go to line 109 (and 149) and replace &$phpmailer with $phpmailer (removing the ampersand, basically), the script will work.

    And to the developer, really? Really? You pushed this out without testing it? Passing a variable by reference when the function doesn't accept one? Jeez!

  9. StephenKorsman
    Member
    Posted 1 year ago #

    Same problem here. @seraphyn - thanks, solved it; will wait for another update.

  10. Callum Macdonald
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the issues you've been experiencing. Just seeing these messages now and I've pushed a new version 0.9.3 which should address this issue.

    I'm not sure why the update triggered this issue as it's been in the code for some time. I also wasn't able to replicate it locally, but it might be because I'm using an older PHP version.

    Hopefully the issue is now fixed. I'll be watching this thread for the next few hours in the case of any further issues.

    Again, apologies for the issue.

  11. utnalove
    Member
    Posted 1 year ago #

    Thanks for the quick action. With PHP 5.4 it's now working fine.

  12. StephenKorsman
    Member
    Posted 1 year ago #

    Thanks! Works fine now!

  13. Surbma
    Member
    Posted 1 year ago #

    Update works. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Mail SMTP
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic