WordPress.org

Forums

Better Font Awesome
[resolved] Error, showing up at the top of every panel page (28 posts)

  1. scott.summerhayes
    Member
    Posted 1 year ago #

    I'm getting this message at the top of every admin page as I try to do work. As far as I can see it is not affecting anything on my website, or the icons, everything looks fine... I just don't know what this means and want it fixed or to just go away.

    --

    Warning: sort() expects parameter 1 to be array, null given in /home/urbanici/public_html/wp-content/plugins/better-font-awesome/better-font-awesome.php on line 183

    Warning: implode(): Invalid arguments passed in /home/urbanici/public_html/wp-content/plugins/better-font-awesome/better-font-awesome.php on line 401

    ---

    Thanks.

    Scott

    https://wordpress.org/plugins/better-font-awesome/

  2. scott.summerhayes
    Member
    Posted 1 year ago #

    My domain is urbanicity.ca... but I have a Coming Soon plugin activated so you won't be able to see the actual site.

    Sorry.

  3. Mickey Kay
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the heads up. It seems like this is a problem that a few people are facing, and I'd like to get to the bottom of it. Can you please answer a few questions for me:

    1. What settings are you using at Settings > Better Font Awesome?
    2. Who is your host?
    3. Are the fonts showing up on the front-end of your site?

    Thanks - I'll get to the bottom of this!

  4. scott.summerhayes
    Member
    Posted 1 year ago #

    SETTINGS
    4.1.0
    jsDelivr
    Minified CSS: Yes
    Remove Existing: No

    HOST
    iPage

    FONTS
    Yes

    Scott

  5. Mickey Kay
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Scott,

    So the fonts are working on the front-end. One other question: can you see the fonts in the TinyMCE drop-down in your admin?

  6. elguiri
    Member
    Posted 1 year ago #

    Same thing happening to me. Dropdown appears but the fonts don't.

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    @elguiri: It is considered impolite to interrupt another poster's ongoing thread unless you are posting a solution or suggestion. As per the Forum Welcome, please post your own topic.

  8. Mickey Kay
    Member
    Plugin Author

    Posted 1 year ago #

    One other question to both of you. What version of WP are you running?

  9. Mickey Kay
    Member
    Plugin Author

    Posted 1 year ago #

    Just to be clear - Better Font Awesome 0.9.6 (just updated) should fix the problem of missing icon previews. Still curious to hear your details Scott. Additionally, I'd love to know if the errors are showing up intermittently (suggesting a connectivity issue with the Font Awesome server), or all the time (suggesting a plugin/version issue). Any ideas there?

    Thanks!

  10. Mike-Ism
    Member
    Posted 1 year ago #

    I believe I have the same or similar issue. I would have started my own thread, but I thought that perhaps my issue could contribute to a solution here.

    Error messages:

    Warning: Invalid argument supplied for foreach() in /home/blank/public_html/blank-content/plugins/better-font-awesome/better-font-awesome.php on line 222

    Warning: sort() expects parameter 1 to be array, null given in /home/blank/public_html/blank-content/plugins/better-font-awesome/better-font-awesome.php on line 183

    Warning: implode() [function.implode]: Invalid arguments passed in /home/blank/public_html/blank-content/plugins/better-font-awesome/better-font-awesome.php on line 401

    edited my comment, because I had originally used "null" to obfuscate personal details. Updated to blank to avoid confusion with the error text.

  11. scott.summerhayes
    Member
    Posted 1 year ago #

    Thanks! With the new update the problem has been solved!

    Scott

  12. Mickey Kay
    Member
    Plugin Author

    Posted 1 year ago #

    To Scott and Mike,

    I can't reproduce this problem locally or on our servers, so I could definitely use your help. Just to clean up this thread, can both of please try the following to see if the error message changes or disappears:

    • Switch CDN from jsDelivr to Bootstrap in Settings > Better Font Awesome - do the fonts still appear for you?
    • Try checking/unchecking the options for minified CSS and removing existing versions of Font Awesome - any change?
    • Would either of you be willing to give me access to your site and permission to turn on maintenance mode to do a bit of debugging? We can discuss the when and how of that?
    • Would either of you be willing to install and test a patch I've created that I think may address some of the issues you're seeing? Again, since I can't reproduce this problem locally I can't fully test this solution, but I do have ideas on what might be going on. If so, I can send you an installable .zip file.

    Thanks you both for your support in resolving this issue. I want to make sure Better Font Awesome stays better!

  13. scott.summerhayes
    Member
    Posted 12 months ago #

    Ok.... The problem did start again, a few hours after I activated the plugin again.

    I have changed the CDN to Bootstrap, and unchecked minified CSS and at the moment is seems to be working. Let's hope it continues to work.

    Sorry, but no, I cannot give you access to my website as we just launched it yesterday and we can't risk any unnecessary issues right now.

    If I do end up having problems I may come back for that test patch if I can't find a similar plugin that does work. So far I can't.

    Thanks.

    Scott

  14. Mickey Kay
    Member
    Plugin Author

    Posted 12 months ago #

    Thanks for the update, I really appreciate your assistance on this one. Just to clarify, you're referring to the errors showing up at the top of the page, correct (another question was introduced on this thread)?

    Also, to get clear, after installing it sounds like the plugin was working for a while before the error appeared - is that the case? I'm really trying to get a sense of whether it's a constant issue (likely plugin coding) vs. an intermittent issue (likely server problems).

    Thanks Scott! Definitely let me know what you encounter as it comes up.

  15. scott.summerhayes
    Member
    Posted 12 months ago #

    Yes, the errors that I originally posted about.

    Warning: sort() expects parameter 1 to be array, null given in /home/urbanici/public_html/wp-content/plugins/better-font-awesome/better-font-awesome.php on line 183

    Warning: implode(): Invalid arguments passed in /home/urbanici/public_html/wp-content/plugins/better-font-awesome/better-font-awesome.php on line 401

    When the message first showed up, I deactivated the plugin. Then, when you introduced the update, I updated and activated again.

    It wasn't right away, but within an hour or two the same error appeared.

    It doesn't come and go though. When it shows up, it stays until I get so sick of it that I deactivate the plugin.

    Like I said, now that I have changed the settings, it appears to be working fine.

    I'll let you know if anything changes.

    Scott

  16. Mickey Kay
    Member
    Plugin Author

    Posted 12 months ago #

    Got it, thanks Scott. I contacted iPages to see if I could get to the bottom of any issues on the server end. They were helpful, but said that unless you tell them to add me as someone who can contact them via your account, they can't tell me much more. If you feel comfortable telling them that I have permission to ask some questions about your site, I would love to talk more with them to see what's up.

    If not, I totally understand. This also sounds super-frustrating and I understand if you just want to move on.

    If you'd like to pursue this, but don't feel comfortable with me contacting iPages, then there are a few things that would be helpful:

    1. Can you provide me with any logs (error, PHP, etc) from iPages.
    2. When things settle, would you be willing to try a beta patch and see if it works for you?
    3. A list of all plugins you have installed. Wondering if there might be a conflict.

    Thanks!

  17. jeffreyd000
    Member
    Posted 11 months ago #

    SETTINGS
    Always Latest () - (nothing else shows in dropdown but that)
    jsDelivr
    Minified CSS: Yes
    Remove Existing: No

    HOST
    HostGator

    FONTS
    Yes

    I'm also getting this...

    Warning: Invalid argument supplied for foreach() in /public_html/wp-content/plugins/better-font-awesome/better-font-awesome.php on line 222

    Warning: Cannot modify header information - headers already sent by (output started at /public_html/wp-content/plugins/better-font-awesome/better-font-awesome.php:222) in /public_html/wp-includes/pluggable.php on line 1121

    and sometimes this..

    Warning: implode() [function.implode]: Invalid arguments passed in /public_html/wp-content/plugins/better-font-awesome/better-font-awesome.php on line 401

    Screen Capture

  18. Mickey Kay
    Member
    Plugin Author

    Posted 11 months ago #

    Hi everyone,

    Thanks for your patience, I've been out of town these last 2 weeks and am just gettin back to the issues list here.

    More and more, it's looking like this is an issue with the server timing out when trying to fetch the latest version of Font Awesome from the CDN. I'll be working on an update over these next few days which should hopefully solve this issue, however since it's a tough one to reproduce, I would love your help once the update is available, if/when any other warnings arise.

    Thanks again for your patience, and stay tuned for an update.

    All the best,
    Mickey

  19. jeffreyd000
    Member
    Posted 11 months ago #

    Welcome back,

    I agree with you, I too think it is a hosting environment issue.
    The only host I have been using on my end is Hostgator (not recommended) due to massive datacenter stability issues.

    Happy to help where I can though,
    Jeffrey

  20. Nemrah
    Member
    Posted 10 months ago #

    downloaded latest version and got this errors:

    Warning: sort() expects parameter 1 to be array, null given in /home/admin/domains/xxxxx/public_html/xxx/wp-content/plugins/better-font-awesome/better-font-awesome.php on line 180

    Warning: implode() [function.implode]: Invalid arguments passed in /home/admin/domains/xxxxx/public_html/xxx/wp-content/plugins/better-font-awesome/better-font-awesome.php on line 398

    have it also installed on my other site on other host and there no problems :)

    So i have two exact the same installs 1 on a shared hosting and 1 on a vps. The vps is giving the errors! When i tried to activate it on the vps it gave me a error "the plugin does not have a valid header"! Then i deleted it and uploaded it by FTP and activating worked. Then i got the error mentioned above. Its frontend & backend.

  21. Mickey Kay
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Jeffrey,

    Apologies for the issues you've been facing. Two updates on this front:

    1. Unbeknownst to me until just now, v0.9.6 included some code that was not meant to be included, which was an error on my part. I've uploaded v0.9.7 which includes a fix. This was causing the plugin to throw an error on <i>all</i> installs, which is indeed not good at all. It took me a while to track this down as a few users (like yourself) were also experiencing the same errors as a result of wp_remote_get() timing out. v0.9.7 repairs the first issue, however the timeout issue is what I'm currently working on. . .

    2. As mentioned, I am currently working on an update that is intended to ensure that you never receive these errors again, and that Font Awesome loads no matter what. This update involves a pretty thorough reworking of the plugin and should be much more reliable. I'll make sure to include clear notes in the update notification when it goes out.

    Thanks so much for your patience and continual feedback :)

  22. jeffreyd000
    Member
    Posted 10 months ago #

    Mickey,

    I'm impressed that you were able to figure out such a seemingly random yet persistent issue. Thank you!!!

  23. Mike-Ism
    Member
    Posted 10 months ago #

    This is getting to be a bit ridiculous. Now I am getting this error, and it persists on the front end and back end:

    Warning: require_once(/home/null/public_html/null-content/plugins/better-font-awesome/Titan-Framework/class-admin-notification.php): failed to open stream: No such file or directory in /home/null/public_html/null-content/plugins/better-font-awesome/Titan-Framework/titan-framework.php on line 22

    Fatal error: require_once(): Failed opening required '/home/null/public_html/null-content/plugins/better-font-awesome/Titan-Framework/class-admin-notification.php' (include_path='.:/opt/php54/lib/php') in /home/null/public_html/null-content/plugins/better-font-awesome/Titan-Framework/titan-framework.php on line 22

    I love the plugin, and you seem very quick to address issues, but it keeps knocking sites offline.

  24. Mickey Kay
    Member
    Plugin Author

    Posted 10 months ago #

    Hi again Mike,

    First things first, I am working on a pretty revamped version of this plugin that will provide numerous fallbacks to avoid timeouts and other issues that have been throwing errors. I know it's hard to wait when things aren't working right, but I did want to let you know this was in the works.

    Secondly, I'm really sorry for the trouble, I've no clue what's going on as the latest version of the plugin works fine for me (even with WP_DEBUG on as well).

    The weird thing about the error you're seeing is that it's referencing a file path that doesn't make any sense - the path includes "null" and "null-content", which don't seem right at all. I'm wondering if something went wrong server-side during the install process by some chance. Any chance you'd be willing to try reinstalling? Just for reference, the one line of code that is throwing this error is from an embedded framework in the plugin that I didn't touch at all:

    defined( 'TF_PATH' ) or define( 'TF_PATH', trailingslashit( dirname( __FILE__ ) ) );

    Essentially, the basic php function dirname( __FILE__ ) is returning a path that appears to be broken, which makes me wonder if the plugin install just didn't quite work correctly. If you could try re-installing, that would clarify this one.</p>
    <p>That said, the problem may be something else entirely - it's just hard for me to debug when I don't see the issue on my side. Can you explain if there were any steps you took other than just clicking the update link for the plugin? Is there actually a "null-content" directory on your install? If not, any idea why trailingslashit( dirname( __FILE__ ) ) would be returning that directory?

    I truly appreciate your patience and understand your frustration. I'll do my best to get to the bottom of this and fully test our new update to assure that it resolves these issues. Would love to give you an acknowledgment in the plugin about page as well, for all your help, if you're okay with that.

    Thanks Mike.

  25. Mike-Ism
    Member
    Posted 10 months ago #

    Thanks for your response. As it turns out, the problem was related to a bad update. It looks like I didn't get all of the necessary files so I was receiving the error.

    I uninstalled the plugin and re-installed it fresh. So far it's working fine, no errors.

    This problem can most likely be attributed to infiniteWP rather than wordpress.org or better font awesome.

    By the way, the "null" directories were simply my attempt to obfuscate any personal details. Sorry for confusion.

  26. Mickey Kay
    Member
    Plugin Author

    Posted 8 months ago #

    I'm going to mark this as resolved y'all!

  27. jeffreyd000
    Member
    Posted 8 months ago #

    Yes resolved! :)

  28. Mickey Kay
    Member
    Plugin Author

    Posted 8 months ago #

    And resolved. . .

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Better Font Awesome
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic