Support » Plugin: Slideshow Gallery » error + short code displays rather than actual gallery

  • Resolved hmacdermott

    (@hmacdermott)


    Howdy! I can’t figure out what has happened to throw this error:

    Warning: Declaration of SlideshowErrorHandler::log_error($num, $str, $file, $line, $context = NULL) should be compatible with GalleryPlugin::log_error($error = NULL) in /home/academicwlu/public_html/wp-content/plugins/slideshow-gallery/includes/errorhandler.php on line 62

    This is happening on several sites in our multi-site installation, like https://macdermotth.academic.wlu.edu/. The slideshow should appear on https://macdermotth.academic.wlu.edu/post-me/.

    We recently updated the pHp to 7.3.7 and are using WP 5.2.2. Any ideas?

    Thanks for your time!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Thread Starter hmacdermott

    (@hmacdermott)

    OK, the slideshow appears just fine, but there is still the error message!

    I just updated the plugin manually because no available updates were shown in the WP Dashboard but I knew there was a security vulnerability in the version we were running (1.6.8) and am getting the same error described above. Please advise how to fix this. Thanks!

    Getting the same error in Query Monitor, what is going on?

    Same error on WP Multisite…

    Same error on a multisite WP installation. Seems the plugin is somehow changing the error report level and is not using the settings in wp-config

    Hope you can solve or answer this problem ASAP.

    Regards

    Felipe Borrero
    Operations Director
    Calipso Comunicaciones S.A.

    I have the same error, any updates? Resolution to this?

    If it’s of any help .. I noticed the issue after recently updating the plugin with WP v5.2.2, and noticed the error when WP updated to 5.2.3 .. I have since removed the slideshow gallery plugin until a resolution will be provided. Error is gone now, white screen is gone now.

    I am also experiencing this error, any updates on how to fix?

    We recently noticed that this message is being generated quite often (on the order of every page load, it seems – which for us is a few hundred thousand messages per month). Looking through the plugin code for the last few versions, and reviewing the message, I see the following:

    Release 1.6.12 introduced a log_error() method to the GalleryPlugin class. This class is then extended by the SlideshowErrorHandler class, which re-implements its own log_error() method – but with different arguments. This is the cause of the problem, because the child class’ definition conflicts with that of the parent class.

    Looking further through the plugin code, I don’t actually see anything that would call the parent object’s log_error() method – so it may be that the solution to this is to remove the log_error() method from GalleryPlugin.

    I also wonder whether reverting to the last release of the plugin (1.6.11 as I type this) would resolve the problem. The code I’m finding here appears to have been introduced in 1.6.12 specifically.

    Im getting the same error after installing the plug-in. However after closing the page, I now cannot log back into my site http://www.raidersgridiron.com/wp-admin/ as the login page doesnt load fully and only displays the error below. Ive tried multiple browsers and all do the same thing. Can someone please tell me how I can get back into my site and remove this crappy plug-in?!

    Warning: Declaration of SlideshowErrorHandler::log_error($num, $str, $file, $line, $context = NULL) should be compatible with GalleryPlugin::log_error($error = NULL) in /websites/ra/raidersgridiron.com/wp-content/plugins/slideshow-gallery/includes/errorhandler.php on line 62

    @sdixon097 I am having the same problem , have you or anyone else found out the solution to this ?
    im fed up with this plugin I rather just change over to another one but now I’m having trouble logging back into my dashboard.

    thanks ,
    Dan

    I found a solution by replacing the php file.

    Woraround for 
    
    https://tribulant.com
    WordPress Slideshow Gallery plugin
    
    Error
    Warning: Declaration of SlideshowErrorHandler::log_error($num, $str, $file, $line, $context = NULL) should be compatible with GalleryPlugin::log_error($error = NULL) in C:\Inetpub\domain.com\httpdocs\wp-content\plugins\slideshow-gallery\includes\errorhandler.php on line 0
    
    Fix
    Replace the current file 
    ..\wp-content\plugins\slideshow-gallery\includes\errorhandler.php
     with new
    errorhandler.php 
     

    Download:
    https://my.pcloud.com/publink/show?code=XZOXiHkZnbvknEdtvCzobNoKvVCTWmq9LaRk

    • This reply was modified 1 year, 10 months ago by t78ch.

    @t78ch
    your workaround works for me: thank you very much!

    Using wp-cli we have the following php warnings :

    
    PHP Warning:  Declaration of SlideshowErrorHandler::log_error($num, $str, $file, $line, $context = NULL) should be compatible with GalleryPlugin::log_error($error = NULL) in /var/www/vhosts/temoins.com/httpdocs/wp-content/plugins/slideshow-gallery/includes/errorhandler.php on line 62
    Warning: Declaration of SlideshowErrorHandler::log_error($num, $str, $file, $line, $context = NULL) should be compatible with GalleryPlugin::log_error($error = NULL) in /var/www/vhosts/temoins.com/httpdocs/wp-content/plugins/slideshow-gallery/includes/errorhandler.php on line 62
    

    Will you fix it in next release ?

    Plugin Author Tribulant

    (@contrid)

    We’re so sorry everyone! We did not receive any notification email for this.
    It will be included in the next update for both paid and free versions of our Slideshow Gallery.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘error + short code displays rather than actual gallery’ is closed to new replies.