Support » Plugin: WP Mail SMTP by WPForms » Error sending test message using gmail smtp

  • Resolved gguerra2017

    (@gguerra2017)



    Hi,

    I get an error when sending a test message… I get the following debug:

    Versions:
    WordPress: 4.9.1
    WordPress MS: No
    PHP: 5.5.38
    WP Mail SMTP: 1.2.2

    Params:
    Mailer: gmail
    Constants: No
    Client ID/Secret: Yes
    Auth Code: Yes
    Access Token: No

    Server:
    OpenSSL: Yes
    PHP.allow_url_fopen: Yes
    PHP.stream_socket_client(): Yes
    PHP.fsockopen(): Yes
    PHP.curl_version(): Yes

    Debug:
    cURL error 77: error setting certificate verify locations:
    CAfile: C:\Program Files (x86)\Parallels\Plesk\Additional\PHPSettings\cacert.pem
    CApath: none (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)
    cURL error 77: error setting certificate verify locations:
    CAfile: C:\Program Files (x86)\Parallels\Plesk\Additional\PHPSettings\cacert.pem
    CApath: none (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)
    Error while sending via Gmail mailer: cURL error 77: error setting certificate verify locations:
    CAfile: C:\Program Files (x86)\Parallels\Plesk\Additional\PHPSettings\cacert.pem
    CApath: none (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)
    cURL error 77: error setting certificate verify locations:
    CAfile: C:\Program Files (x86)\Parallels\Plesk\Additional\PHPSettings\cacert.pem
    CApath: none (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    Well, it easy. Error is written in Debug.
    You will need to fix certificate (make sure it exists there) for Gmail to work. No other options. Please refer to a software documentation that you use to set up a local web-server.

    Hello I have the same problem in a web site which is not hosted in a local web-server.:

    Versions:
    WordPress: 4.9.6
    WordPress MS: No
    PHP: 7.1.16
    WP Mail SMTP: 1.2.5

    Params:
    Mailer: gmail
    Constants: No
    Client ID/Secret: Yes
    Auth Code: Yes
    Access Token: No

    Server:
    OpenSSL: Yes
    PHP.allow_url_fopen: Yes
    PHP.stream_socket_client(): Yes
    PHP.fsockopen(): Yes
    PHP.curl_version(): Yes

    Debug:
    cURL error 77: error setting certificate verify locations:
    CAfile: C:\Program Files (x86)\Plesk\Additional\PHPSettings\cacert.pem
    CApath: none (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)
    Error while sending via Gmail mailer: cURL error 77: error setting certificate verify locations:
    CAfile: C:\Program Files (x86)\Plesk\Additional\PHPSettings\cacert.pem
    CApath: none (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)
    cURL error 77: error setting certificate verify locations:
    CAfile: C:\Program Files (x86)\Plesk\Additional\PHPSettings\cacert.pem
    CApath: none (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)

    So, I have to by a SSL certificate? I don’t know how to “fix certificate for Gmail”.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.