Support » Plugin: WPMovieLibrary » error searching for movie data

  • Resolved stuthemonkey

    (@stuthemonkey)


    I have setup my own API key for TMDB. And it was previously working, but recently I am unable to add any more movies into my collection. When trying to add a movie I go to the metadata tag as normal. Type in the movie title and search. It brings up a list of movie posters. When I click on a movie poster the posters disappear as normal, but nothing gets entered into the metadata.

    When viewing the error console in the browser I see the following:

    wpmoly-editor-meta.js?ver=2.1.4.1:212 Uncaught TypeError: Cannot read property '_tmdb_id' of undefined
        at Object.success (wpmoly-editor-meta.js?ver=2.1.4.1:212)
        at i (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,backbone,utils,jquery-ui-widget,j…:2)
        at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,backbone,utils,jquery-ui-widget,j…:2)
        at y (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,backbone,utils,jquery-ui-widget,j…:4)
        at XMLHttpRequest.c (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,backbone,utils,jquery-ui-widget,j…:4)
    success	@	wpmoly-editor-meta.js?ver=2.1.4.1:212
    i	@	load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,backbone,utils,jquery-ui-widget,j…:2
    fireWith	@	load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,backbone,utils,jquery-ui-widget,j…:2
    y	@	load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,backbone,utils,jquery-ui-widget,j…:4
    c	@	load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,underscore,backbone,utils,jquery-ui-widget,j…:4
    

    Please note that I am using version 2.1.4.1. However I did try to upgrade to 2.1.4.3, and the error still occurs.

    • This topic was modified 1 year, 11 months ago by  stuthemonkey.
Viewing 5 replies - 1 through 5 (of 5 total)
  • More information on this. Running a javascript debugger, when the wpmoly._get() is called to search for the meta data it falls into the success function. However the response it got was <h1>Error thrown</h1><p>[] operator not supported for strings</p>

    • This reply was modified 1 year, 11 months ago by  stuthemonkey.
    Plugin Author Charlie Merland

    (@caercam)

    Hi @stuthemonkey,

    Thanks for the investigation work! I can’t reproduce this anywhere on my test installs, which complicates thing a bit; could you add a console.log( response ); in your wpmoly-editor-meta.js file, right before line 212? That way we may have an insight at what going wrong with the response.

    Regards,

    Charlie

    I can’t edit that file to my knowledge. Unless there is a way directly through wordpress (no ftp access to the server). But using the Chrome inspect tool on line 212 with a breakpoint the value of response is as follows:

    “<h1>Error thrown</h1><p>[] operator not supported for strings</p>”

    The problem appears to be that when this gets called

    wp-admin/admin-ajax.php?action=wpmoly_search_movie&nonce=f54068a915&type=id&data=91314&lang=en

    its returning a web page that says error thrown. []operator not supported for strings.

    So how can debug this issue? I’ve disabled all the newer plug-ins that were installed recently in wordpress. To go back to what it was when i remember this last working. and that didn’t help.

    The only other thing that changed was wordpress got updated to WP 4.7.4

    Plugin Author Charlie Merland

    (@caercam)

    Hi @stuthemonkey,

    Should be fixed by the last update version 2.1.4.4!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘error searching for movie data’ is closed to new replies.