Support » Plugin: Rate my Post - WP Rating System » Error saving settings! Try clearing all caches, including your browser cache!

  • Error saving settings! Try clearing all caches, including your browser cache!

    I still can’t save the settings after I clear the cache.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Blaz K.

    (@blazk)

    Hi @naibabiji,

    thank you for using the support forum. This typically happens after update because the old javascript is still cached in the browser. Did you clear your browser cache – on Chrome hold down Ctrl and press F5.

    If this didn’t solve your problem, can you please verify that you have the latest admin javascript loaded? While you are in admin panel, right click on the document and select View page source. Then search for the following (change example.com with your website):

    
    <script type='text/javascript' src='http://example.com/wordpress/wp-content/plugins/rate-my-post/admin/js/rate-my-post-admin.js?ver=2.8.0'></script>
    

    Can you confirm that you have ?ver=2.8.0 of this script?

    Best regards,
    Blaz

    • This reply was modified 1 year, 8 months ago by Blaz K..
    Thread Starter 奶爸建站笔记

    (@naibabiji)

    Thread Starter 奶爸建站笔记

    (@naibabiji)

    Plugin Author Blaz K.

    (@blazk)

    @naibabiji,

    this is css, please check for js:

    
    <script type='text/javascript' src='http://example.com/wordpress/wp-content/plugins/rate-my-post/admin/js/rate-my-post-admin.js?ver=2.8.0'></script>
    

    Also make sure that you cleared browser cache!

    Do you get any errors in console when you click save settings?

    Blaz

    Thread Starter 奶爸建站笔记

    (@naibabiji)

    Thread Starter 奶爸建站笔记

    (@naibabiji)

    Plugin Author Blaz K.

    (@blazk)

    @naibabiji, that’s very weird – and this happens also if you use a different browser?

    What do you see in the network tab, when you click save settings?

    If you click on admin-ajax.php -> headers -> Form Data (clear the network tab before clicking save settings)

    If you send me the screenshot of form data it would be very helpful. I’m aware that in rare cases websites encounter such an issue after update but I can’t reproduce it. I appreciate your help!

    The form data should look something like this:

    
    action: update_options
    nonce: 54c782514b
    posts: 2
    pages: 2
    ...and more
    

    Regards,
    Blaz

    Plugin Author Blaz K.

    (@blazk)

    PS: hide the nonce value if you share form data 😉

    Thread Starter 奶爸建站笔记

    (@naibabiji)

    May be a conflict with this plugin

    Thread Starter 奶爸建站笔记

    (@naibabiji)

    @blazk
    https://wordpress.org/plugins/wpjam-basic/
    May be a conflict with this plugin

    Plugin Author Blaz K.

    (@blazk)

    @naibabiji,

    did you try saving with that plugin disabled? I tried saving exactly the same settings as you and everything worked fine on my test websites.

    Do you see any errors in php error log?

    If nothing helps, you can remove the code below in wp-content\plugins\rate-my-post\admin\class-rate-my-post-admin.php from line 205 to line 208:

    
    if ( count( $deafult_options ) !== count( $_POST ) - 2 ) { //action and nonce in post request do not count
      echo esc_html__( 'Error saving settings! Try clearing all caches, including your browser cache!', 'rate-my-post' );
      die(); //do not proceed
    }
    

    This will for sure help but I’m still hoping we can figure out what causes such an issue.

    Regards,
    Blaz

    Thread Starter 奶爸建站笔记

    (@naibabiji)

    @blazk I have deleted wpjam-basic and it works fine now.
    3Q

    Plugin Author Blaz K.

    (@blazk)

    Happy to hear that @naibabiji. I will investigate this issue further.

    Regards,
    Blaz

    I have the same issue but only when I try to change the Track IP adresses settings to “yes” on the security tab. It’s a minor issue for me so I just wanted to let you know instead of making a topic for this.

    Plugin Author Blaz K.

    (@blazk)

    @adamfartassi, did you clear browser cache on the settings page? In Chrome that is Ctrl + F5. I’m still investigating this issue, but most commonly it happens because old js file is cached in the browser and I can’t do much about this 🙂 However, there are also cases when this happens due to various other plugins.

    Blaz

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Error saving settings! Try clearing all caches, including your browser cache!’ is closed to new replies.