WordPress.org

Support

Support » How-To and Troubleshooting » Error saving media attachment

Error saving media attachment

  • Fresh install of 2.8.1 for a new site and I keep getting

    Error saving media attachment.

    when I try to upload a media file. My wp-content/uploads exists, has been chmod 777 -R and “Store uploads in this folder” is set to wp-content/uploads in the miscellanous settings. Plugins have been turned on and off, different directory tried but still not working.

    I’ve tried the suggestions on the Image/Media Uploader problems? post but that doesn’t resolve it. Am I missing something obvious here?

Viewing 15 replies - 1 through 15 (of 28 total)
  • I’m having the same problem grianach.
    I did the same things that you did in creating the folder and changing the permissions.
    I also just tried uploading images into the folder via FTP, but the WordPress system didn’t recognize them either.
    The upshot is that I can’t access images in any way for my new WP installation.
    What did I miss?

    (PS- in another WP installation upgraded to 2.8.1 I have no problem with images)

    I solved this problem by deleting and re-creating my uploads folder.

    I also walked away for 24 hours…maybe a caching issue?

    Don’t know why it worked but it did.

    Hi, I´m having the same problem…

    Any new?

    I resolved This Problem, first i created the uploads folder and has been permision 777 all directory.

    Same problem here. In my case I had changed the site url, and the upload seems to be looking in the old place. I restarted Apache and MySQL server, but that didn’t help.

    I suppose I could just try putting the files in the old place, maybe that would help … bogus hack though.

    I think I got it working — if I try to add media from the left column of the admin, it doesn’t work, it’s looking for the wrong directory. (Use the Flash Uploader rather than the Browser Uploader … it tells you specifically where it tried to create a directory to put the file).

    However, if I use the WYSIWYG editor and click on the little “Upload/Insert –> Add an Image” icon at the top of the text entry box, then WP can find and upload the image. You are not done however … You must now put the image in a directory *outside* of your theme directory: in wp-content/uploads/<year>/<month>/ and WP will be able to find and display that image.

    I don’t know if this will work for the long term since it’s such a hack, but it’s working for me at the moment.

    I’m having the same difficulties, but with the Flash uploader the only message I get is the extremely helpful “HTTP error”.

    I’ve experienced several different issues related to this thread, most now resolved.

    – The Upload directory is often defaulted to root or nobody permissions so that all assets are managed by WordPress, rather than uploaded or downloaded via FTP. That allows WP to keep metadata in sync with assets. Through FTP you will be disallowed from making changes to permissions. A root administrator needs to make the changes.

    – The Flash uploader “HTTP error” is a different problem, related to Flash itself. Search the forums for several other threads on this.

    – After all that, I’m still seeing “Error saving media attachment” but only with large files. We added this to the htaccess file with no change.

    <IfModule mod_php5.c>
    php_value post_max_size 50M
    </IfModule>

    Are there other places where upload size is set?

    Hi all,

    I have found that simply leaving a leading slash ‘/’ on your upload URL will cause this problem.

    Settings > Miscellaneous > Store uploads in this folder

    Make sure this is set to:

    wp-content/uploads

    and not

    /wp-content/uploads

    Hope that helps someone!

    edmin, you are a champion! Thank you so much!

    nostradamuszen

    @nostradamuszen

    Same problem here – none of the above hacks worked for me. Using a fresh install of WordPress 2.8.5.

    Isn’t this a MAJOR BUG in WordPress?

    I tried setting permissions on all directories to 777, but still no luck.

    Hang on . . . I set permissions on wp-content to 777

    Then, I uploaded my images via Dreamweaver to uploads/2009/11 . . .

    Still no content when I went to the Library though.

    But, then, I found I *could* upload an image via the flash uploader.

    How bizarre is that???!!!

    It’s a hack, Jim, but not as we know it!

    Cheers, Mark

    nostradamuszen

    @nostradamuszen

    OK, even more confused – it seems to work now without FTPing the images beforehand – maybe it is just a caching issue?

    (Or maybe setting wp-content to 777 sorted it – will we ever know?)

    I wrote an article that may help some of those with wordpress uploading files to the wrong directory: Please check it out here!

    Basically it says go to Settings > Miscellaneous > Upload media to directory… like Edmin’s post says.

    Hope this helps!

    I had the same problem, nothing helped. After an hour of confusion i called my hosting provider.
    They said it was because of some security mode, that PHP could not write files to server. They changed the settings and it works now like a charm.
    Hope, this was helpful for you

    same problem as above.i delete the database and create a new one.simply do it again from the start.works fine 🙂

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Error saving media attachment’ is closed to new replies.
Skip to toolbar