[resolved] Error saving media attachment (31 posts)

  1. lmy
    Posted 5 years ago #

    I'm getting the error (Error saving media attachment) when I try to upload pics. I have tried all of the suggestions included in other posts - even hoped that WP would create the upload file - it didn't. So I created it in the wp-content folder, tried again, and it still didn't work. I'm at a loss as to how to get pics uploaded. Please let me know what else to try!!

  2. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    Dashboard, settings, media, store uploads in this folder


  3. lmy
    Posted 5 years ago #

    Been there, done that... as I mentioned, I've tried everything everyone had previously suggested.... still no luck!

  4. garretble
    Posted 5 years ago #

    I am having the same issue. I am currently receiving the following error via the Flash uploader:

    "image.jpg" has failed to upload due to error
    Failed to write to disk.

    And "Error saving media attachment" via the browser uploader.

    Upon looking through various threads that have been written over the past couple of years, I have attempted/done the following:

    • Cleared cache on multiple browsers. Attempted to upload on multiple computers
    • Checked to make sure I have the most up to date version of Flash.
    • Re-installed the latest version of WP. Currently running 3.1.
    • Added the code `<IfModule mod_security.c>
      SecFilterEngine Off
      SecFilterScanPOST Off
      </IfModule>` to .htaccess
    • Changed permissions for the path to where files are uploaded to 777, then 766; currently set to 755.
    • Changed upload folder in admin panel.
    • Created folder in the root directory labeled "tmp," and added upload_tmp_dir="/tmp" to the php.ini file.
    • Called my hosting company twice and attempted to explain my situation. Asked them to clear/repair any temp folders they might be able to see that I can't. They said everything was working fine and that it was probably a WP error (although all signs point to them). What would be the best verbiage to use, if there is any?

    Are there any other things anyone here might suggest that I have not thought of or seen? Any help would be appreciated.

  5. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    Double check no slash in front of wp-content. Can you ftp to wp-content/uploads/2011/03?

    And your url please.

  6. garretble
    Posted 5 years ago #

    I just double checked, and yes, I can FTP to the folder. I haven't had any problems with WP over the last three years with an issue like this. The last time I was able to upload was on the 8th, weeks after 3.1 came out, so I don't feel like it's anything that WordPress is doing wrong.

    My site is: http://www.hardmode.org

  7. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    garretble http://www.hardmode.org/wp-content/uploads leads to a 404 error. It should show something like this http://lookingoutfromunder.com/wp-content/uploads/2011/.

    Somehow the permissions, which btw you are correct should be 755 for the folders are incorrect.

  8. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    If you can ftp to the folder then you should be able to see the ftp'd image through the browser. Do you have the url of that image?

  9. MD54
    Posted 5 years ago #

    Have you looked at your error log to see what is causing the problem?

  10. garretble
    Posted 5 years ago #

    I uploaded this just now (via FTP) and I seem to be able to see it:


    I am still double checking the permissions for wp-content/uploads, but all right now seem to be set to 755 still.

  11. lmy
    Posted 5 years ago #

    I did the same thing with .../wp-content/uploads on my site and got the 404 error too. I don't have the ability to change permissions on my folders, but I created it within the wp-content folder so wouldn't the permissions get inherited? I am running on a windows server with GoDaddy if this helps at all. Please advise on any other recommendations. Thanks!!

  12. garretble
    Posted 5 years ago #

    @Imy: I am with GoDaddy as well. Did this just start happening with you too? Something smells fishy. SOMEONE CALL DANICA PATRICK; WE NEED THIS FIXED.

  13. lmy
    Posted 5 years ago #

    Via the browser, I can see the pic in the folder, but it's not showing up on the Media panel via the WP Dashboard. What else can I do???

  14. lmy
    Posted 5 years ago #

    I only just installed WP so don't have any other past experience with it.

  15. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    lmy I don't know if permissions get inherited but after decades in computers I assume nothing :^)

    If you can't change permissions you need to ask GoDaddy how to do this or do it for you.

  16. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    garretble If you can upload via ftp you should be able to upload via WP.

    lmy By seeing the image in the browser, I don't mean looking at the folder but looking at the path, the url of the image itself. Can you see it that way?

    As for the 404 error. Maybe this is the way GoDaddy does it rather than the message my host puts up.

    (Edit) As it turns out, it is a 403 error.

  17. MD54
    Posted 5 years ago #

    I run my own server so I don't know if this is possible and would really like to know. My documentroot has a log directory where errors are recorded and I had problems uploading early in my configuration that lead me to wonder about things like permissions.

    It turned out to be an Apache error or Mod_Security more exactly that was liniting what I could do. If this just happened without any changes then maybe you host has made a security change that caused it.

  18. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    garretble There are also errors here, some are related to images, http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fwww.hardmode.org%2f

    MD54 Could be .htaccess could be used or at fault but what I DON'T know about that could fill a book:^)

  19. garretble
    Posted 5 years ago #

    kmessinger, thank you for your help. I am still looking it over, as I continue to have trouble, but I appreciate you time.

  20. lmy
    Posted 5 years ago #

    kmessinger - just catching up on this problem...

    I can see the picture as well as the path, but it still doesn't show up in Media in WP... then, when I remove the pic name in the url and just put in the folder path I get the 404 page. Seems weird if I can get to the pic, but not the folder?!? HELP!!!

  21. garretble
    Posted 5 years ago #

    If it makes any difference, I just found out that photo uploads work via the iPhone app, but I assume that uses a different means of uploading than that of the browser.

  22. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    lmy Actually that is most likely a 403 error which is normal for a folder one doesn't have rights to. The image permissions are 644 so you can see that.

    So, your image did upload using the WP tool but it doesn't show up in the gallery just when you use file manager to see it?

    garretble Not sure what the iphone uses. I would assume some sort of FTP program. Have you tried a different picture? Is the folder wp-content/uploads/images/2011/03 there?

    Another thing for both of you to try is deleting the wp-admin folder and contents. Upload a fresh wp-admin folder and files.

  23. lmy
    Posted 5 years ago #

    I was never able to get the upload to work, thus the error, so I created the folders myself.

    I reinstalled admin and content yet again, but I'm still getting the same error... even created the uploads folder and year/month folders with the image, and still not seeing them in WP.

    I have a support ticket in to GoDaddy about permissions, but this seems more like a bug with WP. I could be wrong, but it seems like everything I've tried is just not working. Does anyone who developed WP ever read these posts??

    Thanks to all for the help given today... If I get anything useful from GoDaddy, I'll post it here. Happy Weekend!! :)

  24. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    Well, let me see. Thousands of users including myself with 2 blogs, having no problem with images. 2 of you having problems. A bug? I think not.

    Have you read and done everthing here?

  25. lmy
    Posted 5 years ago #

    kmessinger... no need to be rude or condescending... software sometimes has bugs in it...!!

    For those using GoDaddy Windows Servers... here's what to do to change permissions... I was finally able to get this to work with WordPress!!

    To Set Directory Permissions on Your Windows Shared Hosting Account:

    Log in to your Account Manager.
    From the Products section, click Web Hosting.
    Next to the hosting account you want to use, click Launch.
    In the Content section, click File Manager.
    Select the directory or directories for which you'd like to set permissions.
    Click Permissions.
    Select both the permissions for the selected files:

    Read — Lets anonymous users view the contents of the selected directory.
    Write — Lets users write to the selected directory.
    Click OK.

    I hope this helps those of you who are like me... i.e. just looking for help with this!!

  26. garretble
    Posted 5 years ago #

    I am still having issues with this situation, but similarly to Imy, I have posted on the GoDaddy forums to see if anyone over there had any answers. I got a note that said they were looking into it, but that's it for now, no definitive answer.

    With Kmessinger's suggestion, I just replaced my wp-admin folder, but unfortunately that didn't change anything. I really feel like it is something on GoDaddy's end. When nothing changes with the software, and it all works one day but not the next, one can only assume it's the hosting. But alas, we are still left to wait and see.

  27. garretble
    Posted 5 years ago #

    I want to say thanks once more to those who helped in this thread, but today I am able to upload images again. I changed nothing on my end, so whatever the server was doing or not doing is apparently now not doing or doing.

    As far as I am concerned, if a mod wants to go ahead and close the thread, then by all means, although we still haven't directly determined what happened. Oh well.

  28. gitanoblue
    Posted 5 years ago #

    Was this issue ever resolved...and was there a solution? I started having the same issue:

    • WordPress image upload errors, both flash and browser
    • godaddy hosting
    • on all my WordPress sites with WP versions 2.7 - 3.1

    I think it may be something in the DNS manager. Yesterday I was swamped and let a local computer company log in to my Godaddy account to adjust email servers on one account for a client...I host the site, they redirect the email to in house servers. I know, I know I shouldn't have let them in, but...

    Anyway, after they did whatever they did all my hosted sites went bad with the WP upload error. Waiting for a call from them to see what they did but in the mean time if anyone has a suggestion I would be thrilled.

    I will post updates when I find out more.

    Thank you.

  29. conorneu
    Posted 5 years ago #

    I'm having the exact same problems on my katiemay.net site, but not on GoDaddy hosting (I use Hostgator). Errors with both flash and browser media uploading. The errors I'm getting:

    With Browser Uploading: "Error saving media attachment."

    With Flash Uploading: "“xyz.jpg” has failed to upload due to an error
    Unable to create directory /home/neptune/public_html/katiemay.net/wp-content/uploads/2011/04. Is its parent directory writable by the server?"

    I am able to upload images via FTP to that exact folder (which I created manually with 755 permissions), but they do not show up in the Media Library. Permissions for those upload folders are all at 755. However, the image does not show up at the correct link (404 error), even though it looks fine in the FTP:

    Meanwhile, images in similar upload folders (same permissions) from before work fine:

    Not sure when exactly it began, but I think when I upgraded to 3.1. I've tried most of the adjustments given above, including upgrading any other potential conflicting plugins. I have some log info, but it just seems to show when it is being retrieved, not any of the error data.

    Any help?

  30. conorneu
    Posted 5 years ago #

    I'm thinking it might be a plugin/theme confliction or something like that. I am using Thesis 1.8 as my theme. Here are the plugins I am using. Anyone here having these same problems with similar plugins/theme?

    • 404 Notifier
    • Akisment
    • cforms
    • Google XML sitemaps
    • NextGen Gallery
    • SEO Friendly Images
    • Shopp
    • Shopp Analytics
    • Shopp Cache Helper
    • Shopp Requirements Check
    • Shopp Sitemap
    • Slideshow Gallery Pro
    • Thesis OpenHook
    • Twitter Tools
    • Twitter Tools - Bit.ly URLs
    • Twitter Tools - Hashtags


Topic Closed

This topic has been closed to new replies.

About this Topic