Support » Plugin: GR Progress Widget » Error retrieving data from Goodreads

  • Resolved bookishbug

    (@bookishbug)


    My GR Progress widget stopped working yesterday. I first checked all the widget settings. They were correct and the same as they had been while it was working. I then removed the widget from my sidebar, put it back, reentered the settings. Still didn’t work. So I tried deactivating, deleting, reinstalling, reactivating, etc. Still not working. I’m getting:
    Error retrieving data from Goodreads. Retrying in 60 minutes.

    • This topic was modified 2 years, 3 months ago by bookishbug.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author cmeeren

    (@cmeeren)

    Sorry, I have nothing to go on here. Did you perhaps change some privacy settings on your Goodreads profile? If not, could you provide a screenshot of your widget settings so I can test them myself?

    I have not changed my Goodreads privacy settings since before I got the widget a couple of weeks ago. It is set to public. It was working fine up until Friday or Saturday.

    Goodreads user ID: 7006228
    API Key: 7CT6mwOexeKD1sbqPOXzVQ
    Name of Shelf on Goodreads: currently-reading

    Like I said, all my settings for the widget are exactly the same as they were when it was working properly. The problems started by not showing my reading progress bar, then not showing a new book I started, then this error message. And even after reinstalling the widget, it still will not work.

    Plugin Author cmeeren

    (@cmeeren)

    Your settings work for me, so I have no idea what’s wrong, sorry.

    My husband tried the widget on his website with his Goodreads and is getting the same error message. And I just found a post on this forum from 2 days ago with the exact same issue and “Sorry. Can’t help you.”
    I have two other Goodreads WordPress widgets that work perfectly fine, so maybe this widget needs some work.

    Plugin Author cmeeren

    (@cmeeren)

    Since I have received a few other reports since making a small change to the plugin, I have now reverted the changes I made. Please update the plugin to version 1.5.2 and try again.

    For the record – I still have no idea why it doesn’t work. But maybe it’s fixed now.

    • This reply was modified 2 years, 3 months ago by cmeeren.
    Plugin Author cmeeren

    (@cmeeren)

    @bookishbug, can you check if version 1.5.2 works? Remember to re-save your widget settings after updating.

    I also am having a problem connecting this plugin 1.5.2 to my goodreads account also. I also can not connect an e reader called Hyphen either, but then Goodreads may not allow this connection any longer.

    I was able to connect yournextread.com to goodreads, so I am thinking that there may be a problem either with goodreads timing out with your request or the protocol is not working properly. This is too sad cause I would love a reading progress widget on my website.

    Plugin Author cmeeren

    (@cmeeren)

    To enable me to debug this, please post your exact widget settings for:

    User ID
    API key
    shelf name on goodreads

    UserID 288944

    API Key xAQ9JsSBVNoMQQMZqx6NqQ

    shelf name on goodreads currently-reading

    Plugin Author cmeeren

    (@cmeeren)

    Works fine for me: https://pasteboard.co/GSJlFOf.png

    So it must be something on your end. It might be a conflict with another plugin. Try deactivating all other plugins and then re-saving the GR Progress widget settings, and refresh your blog to see if it’s fixed. If it works, enable other plugins one by one (and re-save widget settings and reload after each) to determine which plugin causes the problem – I’m very interested in knowing that.

    If it still doesn’t work with all other plugins disabled, then I have no idea what could cause the problem. Perhaps your web host has disabled certain outgoing connections?

    Dude. You can’t keep saying “Works fine for me” and blaming it on the way your customers are running their websites.

    Plugin Author cmeeren

    (@cmeeren)

    Dude. I don’t have customers. I’ve made this plugin for myself and have posted it here in case it’s useful for anyone else, and with over 600 active installs and only a handful of bug reports, I’d say the world is a slightly better place because of it. You have not in any way paid me to make the plugin work for you, are can’t make any kind of demands or expect any kind of service from me. I’m a normal guy, just like you, with my own life to lead, and fixing bugs that don’t affect me and that I can’t easily debug because it works on all systems I test it on is pretty far down my priority list.

    WordPress is a complex system, and it’s entirely possible that certain plugins can interfere with other plugins. There’s not necessarily anything I can do about that, nor can I test my plugin with 100,000 other plugins to make sure. Furthermore, what some webhosts might decide to do (e.g. block outgoing connections unrelated to serving the website they host, either to save bandwith or to prevent illegal file sharing) is completely out of my hands.

    If you don’t have anything more constructive to add (my question from a few posts ago is still unanswered), I don’t really have anything more to add.

    No, the rolled back plug-in doesn’t work.
    No, it’s not an issue with my hosting, because I have plenty of other plug-ins and widgets that draw from external sites and work perfectly fine.
    No, it’s not caused by my other plug-ins, because even with all of them deactivated, yours STILL doesn’t work.
    All I’m saying, is if you’re going to make something public for others to download and use, don’t act like THEY are doing something wrong just because it works for you. YOU built it. YOU know how it’s supposed to work.
    I appreciate you giving tips on what may be causing it, but instead of saying “Works fine for me” maybe “I’ll look into it when I have a bit more time. Thank you for your patience.”?
    I really liked the widget, when it was working. It was much more customizable than others I’ve found. I’m just frustrated that every “fix” I’ve found on it ends with the author “not having anything constructive” to add.

    So you are able to make it work, I deactivated all except for your plugin and had no luck. I am beginning to think it might be where I have my site hosted. I do have other plugins that use goodreads and they all work.

    What about memory how much memory does it use, would you know. I have had a problem with that before. I will increase memory and see if that works, other than that your plugin appears to be timing out before it makes the connection to Goodreads. Very Strange, too bad it is a nice plugin.

    Thanks,
    Diane

    Plugin Author cmeeren

    (@cmeeren)

    Hi Diane,

    The plugin shouldn’t use much memory at all. If you have deactivated all other plugins and you have other plugins that connect to Goodreads, then it’s quite possible that there actually is something wrong with my plugin. However, since it works when I test it and I can’t reproduce the problem, I’m sad to say I can’t really find out why it doesn’t work, let alone fix it.

    If I ever get the time, I’ll check out the possibility of adding debug messages to the plugin to make it easier to debug problems such as these. That way, users could send me their logs and I could use those to hopefully find and fix any problems. Unfortunately I’m swamped with other work for the foreseeable future, so I won’t be able to do this anytime soon.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Error retrieving data from Goodreads’ is closed to new replies.