Support » Plugin: NextGEN Public Uploader » ERROR: "Requires NextGEN Gallery to work", but I already have it

  • Resolved OMatthew

    (@omatthew)


    Hi, I have NextGEN gallery and NextGEN public uploader installed and activated but this error shows up in my dashboard, “NextGEN Public Uploader requires NextGEN Gallery in order to work. Please deactivate NextGEN Public Uploader or activate NextGEN Gallery.”

    My NextGEN galleries are showing up fine but I only see the shortcode for the uploader on my published page.

    I’ve tried re-installing and reactivating the plugins but that didn’t work. Can anyone help?

    Thanks!

    http://wordpress.org/extend/plugins/nextgen-public-uploader/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Same problem here. I am running WP with Buddypress

    Okay. Here is the fix. I am running WP with Buddypress on a WPMU install.

    With this setup you must install all plug-ins via the master dashboard which control all of your sites. But if you opt to network enable the add-on at install time while your Buddypress plug-in is active; the plug-ins will not be added to the site dashboard. If you compare the WPMU dash to the site plug-in page you will notice that the additional plug-ins are not there.

    So to make everything work properly: Disable all plugins in the MPMU master dashboard. Everything NextGen and BP related! Then browse to the site dashboard. You will see that all the plugins have now appeared in the site dash. Now you can re-enable everything.

    Cheers!

    @jimmersd: Thanks for your description of a possible solution!

    I am using WPMU without Buddypress.

    – I have deactivated and again activated both plugins in the network dashboard -> no change!

    – I have activated both plugins in the site dashboard -> it works again.

    It seems like the new version of NextGEN Public Uploader
    is not working on WPMU installations.
    I am running NextGEN Gallery 1.9.6 and NextGEN Public Uploader 1.6.1
    on another WPMU blog activated from the network dashboard – it’s doing fine there!!!

    I didn’t re-enable the plug-ins in the WPMU dash. Only in the site dash. The order of enable might have something to do with it. I enabled the NextGEN stuff first and then Buddypress.

    So we are experiencing the same:

    Both plugins do only work if they are both enabled in the site dashboard!

    This seems to collide with what is written on the plugin WP-site
    under ‘Installation’:

    1. Upload the nextgen-public-uploader folder to the plugins directory in your WordPress or WPMU installation.

    Hopefully someone of the developers are recognising this thread here 🙂

    @jimmersd

    Your solution worked for me. So simple…thanks a lot!

    Having the same problem, have BuddyPress and followed your instructions and it worked. Thank you!

    Hi, I’m having the same issue but I don’t have Buddypress, just the WPMU install. Any ideas?

    Thanks!

    Both plugins do only work if they are both enabled in the site dashboard!

    I had installed and activated both plugins from the WPMU dashboard; I’m wondering if there’s another plugin that might be causing interference (as stated above, no Buddypress installed)…

    Just a follow-up, I network de-activated all plugins, then re-activated, starting with Multi-site User Management, followed by NextGEN Gallery, NextGEN Public Uploader, then all the others. Still getting error message.

    Edit: duh, missed the keyword “site” dashboard, working now! Thanks for pointing that out!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘ERROR: "Requires NextGEN Gallery to work", but I already have it’ is closed to new replies.