Support » Plugin: User Submitted Posts » Error : Required Login

  • Resolved Gurmeet Singh

    (@guruitengineer)


    Hi, I’m using the User Submitted Posts v2016081 and facing a issue with user submit form. If I checked the “Use registered username as post author. Valid when the person submitting the form is logged in to WordPress.” in dashboard. User submit form always ask for login.

    Please suggest me a solution to use registered username as post author if user is logged. But please don’t ask to login if not logged in.

    • This topic was modified 6 years, 5 months ago by Gurmeet Singh.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jeff Starr

    (@specialk)

    It sounds like maybe you have the setting, “Require User Login” enabled. If you disable that option, the form always will be displayed to all users, logged in or not.

    • This reply was modified 6 years, 5 months ago by Jeff Starr.
    Thread Starter Gurmeet Singh

    (@guruitengineer)

    No, the “Require User Login” is disabled. Still, I’m seeing this error on post-submit-page.

    Plugin Author Jeff Starr

    (@specialk)

    Hmm.. interesting. If you have a URL where the form is displayed, I would be glad to take a look.

    Thread Starter Gurmeet Singh

    (@guruitengineer)

    Please find the below user submitted post form URL.

    user-submit-post

    Below is the current settings screenshot attached.
    https://guruitengineer.in/wp_plugins/User-Submitted-Post.PNG

    Note : Site link is only for testing. It’s not for end user.

    Plugin Author Jeff Starr

    (@specialk)

    Thanks, I am checking it.. what do you have for the setting, “User Name”, it looks like it is not enabled. If so, try enabling it, so users who are not logged in can enter their name 🙂

    Thread Starter Gurmeet Singh

    (@guruitengineer)

    The field “User Name” is disabled. But I have set the Assign Author for the post via user submitted post.

    Please find the below image.
    Assigned Author

    Plugin Author Jeff Starr

    (@specialk)

    Yes, the setting “Assign Author” is smart — it tells the plugin to display the Username field only when the user is NOT logged in. So the solution is to enable the Username field if you want to collect username information, regardless of any other settings. Then if you want to use registered username, then enable that setting as well. Try it, you’ll see.

    Thread Starter Gurmeet Singh

    (@guruitengineer)

    Sorry, I don not want to collect user name information. I want to just the a way to submit a post with out logging in. But, I’m getting this required login error.

    Plugin Author Jeff Starr

    (@specialk)

    Okay, so if you do not want to collect username information, the setting “Registered Username” is useless and should be disabled. Disable that setting and you should be good to go.

    • This reply was modified 6 years, 5 months ago by Jeff Starr.
    Thread Starter Gurmeet Singh

    (@guruitengineer)

    Yeah, It will work but the problem is, after disabling “Registered Username”, if the registered user will post using user submit post form. It’s assigned to default user and I need to update it manually.

    Plugin Author Jeff Starr

    (@specialk)

    So you basically have two options:

    – collect username information for all users
    – or do not collect username information for any user

    The form isn’t set up to only collect username info for logged-in users. It’s all or none. If all, then you can save logged-in users a step by enabling the setting “Registered Username”. If you need the logged-in user name info, then I would just include/enable the Username field.

    • This reply was modified 6 years, 5 months ago by Jeff Starr.
    Thread Starter Gurmeet Singh

    (@guruitengineer)

    Ok thank you 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error : Required Login’ is closed to new replies.