Support » Plugin: Customer Reviews for WooCommerce » Error: Request failed with status code 404

  • Resolved sergiom87

    (@sergiom87)


    Hi,

    I keep receiving emails from CR with this error.

    Hello,

    There is an issue with posting review data to your shop. Please make sure that Customer Review plugin is updated and works correctly.

    Technical details:
    Error: Request failed with status code 404

    Best regards,
    Customer Reviews Plugin

    I have no idea why it gives a 404 since everything seems to be working fine.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Tried myself and noticed that all these emails i’ve been getting are reviews that clients are doing. However, I don’t receive them on my website, instead, i receive the email with the error.

    Plugin Author cusrev

    (@ivole)

    Thanks for trying our plugin!

    Can you please let me know values of the following two fields on “General” screen in the standard WordPress settings?

    – WordPress Address
    – Site Address

    It would be even better, if you could share a screenshot of these settings.

    Hi
    Here it goes

    Website greatiamwear.com wordpress greatiamwear.com/secure-login

    https://ibb.co/dGzKW1g

    Let me know when I can edit this to delete this info for security reasons.

    Plugin Author cusrev

    (@ivole)

    Thanks for sharing a screenshot but I asked for a different one 🙂 Can you please share a screenshot of the “General” screen in the standard WordPress settings? The screenshot that you shared is from WooCommerce settings.

    Sorry, there you go

    https://ibb.co/xMKjJQ4

    Plugin Author cusrev

    (@ivole)

    Thanks for providing the screenshot.

    We checked the logs and it looks like your site used to have HTTP protocol but now is on HTTPS. Is it correct?

    I never used http.

    I remember that I first used the plugin on my staging site (also https), dunno if that helps.

    Do we have a solution?

    Plugin Author cusrev

    (@ivole)

    Based on the screenshot you provided, I see that you are using TranslatePress plugin. Is it correct?

    Correct

    Plugin Author cusrev

    (@ivole)

    Ok, than it is clear where HTTP comes from. There seems to be a known issue with TranslatePress: https://wordpress.org/support/topic/translatepress-is-trying-to-load-over-http/ . It changes HTTPS to HTTP when our plugin retrieves the website URL. There are two ways to solve the problem:

    1. Reach out to TranslatePress support to check the problem with HTTP/HTTPS. TranslatePress should not change HTTPS to HTTP.

    or

    2. Configure a redirect from HTTP to HTTPS on your site. I see that you already have the redirect configured for GET requests but not for POST requests. Reviews are transmitted to your site via POST requests, and since there is no redirect for them, they are failing.

    Thank you for the support!

    I will try with TranslatePress support too.

    2 – From what I understood it isnt possible to redirect redirect POST requests from HTTP to HTTPS
    I would need that the form sends request to HTTPS originally

    rosualex

    (@rosualex)

    Hello @sergiom87 ,

    I don’t know how to write to you, but I have the same issue that you had in a thread.
    Can you help me with the solution?

    https://wordpress.org/support/topic/geolocation-pricing-and-caching/page/2/

    Thank you very much,
    Alex
    alex.rosu23@gmail.com

    sergiom87

    (@sergiom87)

    Hi @ivole

    Any other idea? Tried with Really Simple SSL but nothing changed.

    It’s marked as solved but it isnt.

    @rosualex i’ll send you an email.

    Plugin Author cusrev

    (@ivole)

    As I wrote earlier, the problem is caused by a bug in a third-party plugin that you had installed. It changes HTTPS to HTTP in your site’s URL returned by standard WordPress functions.

    Unfortunately, there is not much we can do here if you have a third-party plugin that consistently changes HTTPS to HTTP while you site is actually HTTPS. I made two suggestions earlier in this thread. Then, you wrote that it wouldn’t be possible to redirect POST requests. In this case, the only option left is to resolve the bug in that third-party plugin.

    This thread is marked as resolved because I have provided you exhaustive explanation why the problem happens and how to fix it. Unfortunately, we cannot fix it from our end because it is caused by a bug in another plugin that you chose to install on your site.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.