Support » Plugin: Really Simple SSL » Error redirecting to wp-admin

  • Resolved sperrenoud

    (@sperrenoud)


    Hello dev,

    When i get access to my website with https://www.link216.ch/wp-admin/ (or with http) i get an error from my theme.

    Fatal error: Call to undefined function zn_show_nav() in /home/clients/462d353d3f85555a6ae60b39532526bc/web/wp-content/themes/kallyas/components/theme-header/header-components.php on line 814

    When i access http(s)://link216.ch/wp-admin i get redirected to https://www.link216.ch/wp-login.php?redirect_to=https%3A%2F%2Flink216.ch%2Fwp-admin%2F&reauth=1 and everything is working well…

    Now i would like to redirect, with htaccess, all request without www to www. and it’s not possible with this problem.

    Heres is my htaccess config:

    # BEGIN WPSuperCache
    # END WPSuperCache

    # BEGIN rlrssslReallySimpleSSL rsssl_version[2.3.9]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    #RewriteCond %{HTTP_HOST} !^www\.
    #RewriteRule ^(.*)$ https://www.%{HTTP_HOST}/$1 [R=301,L]

    </IfModule>
    # END rlrssslReallySimpleSSL

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Themme buiilder (Kallyas) already contacted and said not a theme problem…

    Any solution would be appreciate.

    https://wordpress.org/plugins/really-simple-ssl/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    The difference is not in the www: when redirected, you get redirected to wp-login.php, which works. When you access wp-admin directly, you get the error.

    So if you access https://www.link216.ch/wp-login.php, there’s no error.

    So there seems to be an error in the rewriting of wp-admin to wp-login.php.

    I would try re-saving the permalinks, and check if you have a security plugin that is blocking the default admin url.

    Thread Starter sperrenoud

    (@sperrenoud)

    Hi Rogier,

    Perfect suggestion: WP Cerber settings block redirection.

    Thanks for helping

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Good to hear!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error redirecting to wp-admin’ is closed to new replies.