WordPress.org

Forums

Google Analytics Dashboard for WP
[resolved] Error: redirect_uri_mismatch (Error 400) - Requiring re-authorizing (8 posts)

  1. Adam_Murphy
    Member
    Posted 2 years ago #

    Hi!

    After updating wordpress (not immediately, but a couple of days after), I noticed that Google Analytics Dashboard for WP asked me to authorize the plug-in. Note that it already worked fine for nearly a year now.

    I press 'authorize' and then I am forwarded to the dashboard with my API details etc. Then it says 'Use this link to get your access code'. I press Get Access Code - only to be sent to a Google Error 400 site stating the following:

    400. That’s an error.

    Error: redirect_uri_mismatch

    Application: Google Analytics Dashboard for WP

    You can email the developer of this application at: (my email)

    The redirect URI in the request: urn:ietf:wg:oauth:2.0:oob did not match a registered redirect URI

    Learn more

    Request Details
    That’s all we know."

    I thought that perhaps I could add the redirect directly in the API settings, but the API states it is not a valid URI.

    Would really appreciate some help with this one. Thanks in advance! Let me know if you need any more information.

    Ps - Error log says - "Last error N/A", so there's no real error per se. More of a communications problem between the plug-in or google?

    https://wordpress.org/plugins/google-analytics-dashboard-for-wp/

  2. Alin Marcu
    Member
    Plugin Author

    Posted 2 years ago #

    Any particular reason for using your own API Project? If you uncheck that option in General Settings you'll be able to authorize.

    If you need to use your own API, you'll have to add:

    urn:ietf:wg:oauth:2.0:oob

    in Google Console, in your redirect URIs field.

  3. Adam_Murphy
    Member
    Posted 2 years ago #

    Hi Alin,

    Thanks for the quick reply.

    No, I just followed a video tutorial on youtube - so, no idea why I got my own API project.. I'm a bit of a noob on this topic. :/ If I uncheck that option in general settings - does that mean I will lose all my google analytics data?

    When trying to add the above API in the Google Console under authorized redirect API I get the following message:

    "Redirect URL "urn:ietf:wg:oauth:2.0:oob" is not allowed for this type of OAuth 2 client."

    Any idea how I can 'urn:ietf:wg:oauth:2.0:oob' in there validly?

    Ps - Very impressed with the plug-in until now though. Just hoping to get it back on track. :)

  4. Alin Marcu
    Member
    Plugin Author

    Posted 2 years ago #

    Your stats are safe, the API Project only handles the requests and the autorization process.

  5. Adam_Murphy
    Member
    Posted 2 years ago #

    Thank you, unhooked 'use your own API project credentials' and now it works again. Resolved.

  6. JPMunupe
    Member
    Posted 1 year ago #

    Hi Alin,

    Thanks for the info above as I was on the same situation today. My question though is still if I want to use my own API then what is the real solution to this.

    How can we get the urn:ietf:wg:oauth:2.0:oob on the Redirect URL to be allowed.

    Thanks for your reply.

    :)

  7. Alin Marcu
    Member
    Plugin Author

    Posted 1 year ago #

    Make sure you read the reasons for using/not using that feature: Google Analytics Dashboard WordPress

    On my YouTube channel, you can find an old tutorial that may help you through the process of correctly setting that up: https://www.youtube.com/user/TheDeConf

  8. JPMunupe
    Member
    Posted 1 year ago #

    Hi Alin,

    Thank figured it out on the creation of the OAuth 2 client, under Client ID I had to choose Install Application when the web application seem to be the obvious choice. Then I had to select Other under Install application type. DONE

    Now it's connect and works great.

    Thanks
    JP

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Analytics Dashboard for WP
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.