Error Reading Scan

  • I am having the same problem that was reported 4 months ago but not resolved on this thread. I activate the scan, it goes through the motions and finishes, but then I get an error message “Error Reading Scan”. I also get Warning: fopen(D:\Inetpub\myusername/wp-content/uploads\profiles\) [function.fopen]: failed to open stream: No such file or directory in D:\Inetpub\myusername\wp-content\plugins\p3-profiler\classes\class.p3-profiler-reader.php on line 153

    I’ve changed the permissions on the uploads folder to 777 and that doesn’t make a difference. The files are created and I can see them all listed, but the Size is showing as 0B, and 0 Visits. If I try to View one of them I get another error: No visits recorded during this profiling session. I’m not using any caching, my IP is correct, and I’m doing an automated scan. I turned on the Debug Log but that appears to be empty too. Any other suggestions?

    Thank you, Carol


Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor Kurt Payne


    Hi Carol,

    There should be at least 2 files in the profiles folder. The default files are index.php and .htaccess and they’re there for security reasons.

    Do you have any other files there? Any files with “.json” on the end?

    If you don’t, then there’s one of two things happening:

    1.) P3 cannot write the files
    2.) P3 isn’t recording your traffic

    For #1, this would show up in your debug log. Since your debug log is empty, too, then I would guess that P3 isn’t picking up your traffic for some reason. The debug log shouldn’t be empty, though. Even if your IP was wrong, the debug log would show the last 100 recorded hits to your site from any IP.

    You’re not using any caching? Nothing under the “Drop-ins” list on your plugins page?

    Have you tried turning on P3 (in Chrome, for example), then surfing your site from a different browser (e.g. Firefox), then checking the debug log?

    Are you using an opcode cache like wincache? P3 should tell you on the help page if you look up “Am I using an opcode cache?”

    Plugin Contributor Kurt Payne


    Hi Carol,

    Did my reply help?

    Sorry, I went on vacation last week.

    Thank you for your response. Unfortunately I am still at a loss. In the profiles folder, there is index.php (53 Kb) and .htaccess (14 Kb). There is a scan_date_random8charhexvalue.kson for each time I did a scan, but they are all empty.

    I’m not sure what you mean by Drop-ins list. Your help page told me I am using IonCube and Zend Optimizer (but I don’t know where).

    I disabled each plugin, re-ran the scan and checked the opcode on your help page, but nothing happened differently. I am now left with only your P3 plugin. WordPress tells me I have only 1 active plugin, but the P3 plugin tells me that there are 2 currently active. I have no idea what the extra plugin is!

    Another thing: when the scan starts, I very briefly see a window that says “The Fast CFI handler was unable to process the request. FastCGI process exited unexpectedly. Error Number: -1073741819 0xc000 5. Error Description: Unknown Error”

    I tried turning it on in Chrome and surfing the site using Firefox as suggested but there is still nothing in the debug log.

    I am going to be moving this site to a different server and updating to the latest version of WordPress so maybe that will make a difference. Just not sure when I’ll get around to moving it!

    thanks so much for your suggestions.


    Plugin Contributor Kurt Payne


    Hi Carol,

    It seems like you have a conflict with IIS + IonCube + Zend Optimizer. I would recommend that you don’t use P3 with this combination or you find/disable the offending php extension temporarily. It looks like other users have reported this problem (though not with P3):


    In the mean time, you can scan your site with http://webpagetest.org/ and http://gtmetrix.com/ to find optimizations on your site. Their recommendations are good, but they are aimed at linux sites, so be aware that you’ll need to do some testing/tweaking.

    I know this isn’t the answer you were looking for, and I’ll leave this marked as unresolved until I get a chance to test this combo with P3. I hope the other recommended sites/tools help you out!

    Do you know how I can identify what is using Zend Optimizer?

    So this might be the push I need to actually move this site to my linux server. So much to do, so little time!

    Thanks for the two other reference sites. I’m familiar with the first one but not the second, and that looks quite helpful too.

    Thank you as well for your help in trying to track this down. I’ll let you know how it works once I get over to linux.

    Plugin Contributor Kurt Payne


    Hi Carol,

    Do you know how I can identify what is using Zend Optimizer?

    If Zend Optimizer is installed as an extension, then it’s loaded by php whenever a request is made to any php file. It’s not loaded dynamically like normal php code.

    I don’t think it’s required unless you have any paid code on your site. Depending on your exact version, Zend Optimizer may be acting as a loader for Zend Guard encoded files. You should be able to identify these files from the contents.

    I hope this helps! Sorry about the late reply.

    I too am getting most (though not all) of my P3 scans ending with “Error reading scan”. The json files are being created, but I see corrupt lines in several of them. What could be causing that?

    I have just deleted and reinstalled P3 – to no avail.

    Plugin Contributor Kurt Payne


    Hi Big Mac,

    Can you send me one of the json files? I’m kpayne -at- godaddy -dot- com.

    3 corrupt json files sent.

    Plugin Contributor Kurt Payne


    Replied. Let’s continue to work over e-mail to get this resolved.

    We are having this issue too.

    Warning: fopen(D:\inetpub\vhosts\ourwebsite.com\httpdocs/wp-content/uploads\profiles\) [function.fopen]: failed to open stream: No such file or directory in D:\inetpub\vhosts\ourwebsite.com.com\httpdocs\wp-content\plugins\p3-profiler\classes\class.p3-profiler-reader.php on line 153

    Please note that if this is a plugin that only works with a Linux server, and not with a windows server, it should be addressed in the documentation. If it’s not the case, what is the problem here?

    Plugin Contributor Kurt Payne


    Hi Allie,

    P3 does work with windows servers.

    For this particular issue, do you have a wp-content/uploads/profiles folder? Does it contain any files?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Error Reading Scan’ is closed to new replies.
Skip to toolbar