Support » Plugin: Braintree for WooCommerce Payment Gateway » Error processing payment (Merchant account must match 3D Secure)

  • Resolved markiljas

    (@markiljas)


    Hello,

    I noticed an error with the last attempted purchase, because the order failed. When opening the order, the note says:

    Error processing payment. Reason: Merchant account must match the 3D Secure authorization merchant account.

    I’m using Price Based on Country plugin for currency conversion and zone pricing and had no issues so far, but this happened after I updated your plugin yesterday so I assumed it was due to that. The Braintree didn’t even capture the failed attempt. Should I downgrade the plugin? Or could it be something else?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support tamarazuk

    (@tamarazuk)

    Hi @markiljas,

    Thanks for writing to us about our plugin! I’m sorry to hear that the plugin isn’t working as expected. I am happy to help out here. 🙂

    I’d like to review our recent changes to see if anything could explain this strange issue. Do you happen to recall what version of the plugin you were using before updating to the latest version?

    Thanks,
    Tamara 🙂

    Thread Starter markiljas

    (@markiljas)

    My apologies, I’ve only now noticed that I have ventured into the wrong plugin support, I’m using a different Braintree plugin. Sorry for the confusion!

    Kind regards,
    Marko

    Plugin Support tamarazuk

    (@tamarazuk)

    Hi Marko,

    No worries at all, thanks so much for letting us know!

    Stay safe and have a great day,

    Tamara 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error processing payment (Merchant account must match 3D Secure)’ is closed to new replies.