Support » Plugin: WooCommerce » “Error processing checkout. Please try again.” after 100% discount

  • Resolved lexodusk

    (@lexodusk)


    I updated Woocommerce to Version 4.7.0 and WC Smart Coupons to 4.7.8 and that’s when the error starts happening. I was using a 100% discount on my product as a freebie and it was able to go through without a hitch previously. Now it only works if the discount isn’t 100%. Any help is appreciated.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Support RK a11n

    (@riaanknoetze)

    Hi there,

    I’ve just run a 100% discount code test on my local testing website using the latest versions but couldn’t replicate the same thing – everything went through as expected.

    With this in mind, are you still seeing the same thing after doing a conflict test as outlined at https://docs.woocommerce.com/document/how-to-test-for-conflicts/?

    Thread Starter lexodusk

    (@lexodusk)

    Hi,

    I’ve disabled most of my plugins and tested, but it’s still the same. The error persists on 100% discount. Is there any other way to resolve this? Thanks in advance.

    Plugin Support RK a11n

    (@riaanknoetze)

    What happens if you disabled *all* of your plugins (Except WooCommerce) and switch to the default TwentyTwenty or Storefront themes?

    Thread Starter lexodusk

    (@lexodusk)

    Hi,

    I’ve disabled everything except Woocommerce, changed to TwentyTwenty theme, but still nope. Error still persists.

    Thread Starter lexodusk

    (@lexodusk)

    I reverted back to Woocommerce 4.6.2 and now it works fine. Could be just my configuration, but just to inform that 4.7.0 has lots of issues if I’m seeing the forum correctly.

    I can confirm the same exact issue on multiple client sites. Smart Coupons 4.12.2 and Woocommerce 4.7.0 using 100% coupon causes a checkout error.

    Please fix ASAP please as we will be using a lot of coupons for the upcoming holiday.

    I wonder if it’s related to this issue in 4.7.0:
    https://github.com/woocommerce/woocommerce/issues/28232

    • This reply was modified 7 months, 1 week ago by contemplate.

    Also having this issue.

    It seems it may be limited to subscription products, but it’s not clear. I’ll do conflict testing.

    • This reply was modified 7 months, 1 week ago by supaiku.

    @supaiku good catch. All the products I tested where I got this error were subscription products. I did not test on simple products. Let me know what you find.

    I am facing same issue with WC 4.8.0. is there any solution anybody has figure out that?

    • This reply was modified 6 months, 1 week ago by kiritp.

    I had this same issue and WooCommerce support directed me to check the
    “Allow $0 initial checkout without a payment method” option under WooCommerce > Settings > Subscriptions. After enabling that setting, I was able to check out successfully with a subscription product and 100% discount code applied. Hope this works for others experiencing this issue.

    contemplate

    (@contemplate)

    Perfect @bluecap that worked for me!

    Plugin Support Ena P (a11n)

    (@drwpcom)

    I’m going to go ahead and mark this thread as Resolved after bluecap’s response. If you have premium extensions from WooCommerce.com and need support, please feel free to contact us from https://woocommerce.com/my-account/create-a-ticket/.

    Hi

    I am still facing this issue even after checking the “Allow $0 initial checkout without a payment method” option under WooCommerce > Settings > Subscriptions.

    My Woocommerce verison is 4.8.0 and Woo Subscriptions version is 3.0.11.

    Please help.

    Thank you, @bluecap I had this same problem. That fixed it.

    Thread Starter lexodusk

    (@lexodusk)

    Hi, after 2 months and 3 weeks, this problem has not yet solved for me when I update to 4.9.2. I have insisted on not upgrading and still remained at the only version that allows coupon to work at 100% off which is 4.6.2. My settings was already at what @bluecap mentioned, and still unable to work. Unchecking it will proceed to the payment page but an error that says “amount must be greater than 0”. Checking it leads to “Error processing checkout. Please try again”

    • This reply was modified 4 months, 2 weeks ago by lexodusk.
Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.