WordPress.org

Support

Support » Plugins and Hacks » WP Ajaxify Comments » [Resolved] Error "Please type a comment" on IE 8 w/ comment added already

[Resolved] Error "Please type a comment" on IE 8 w/ comment added already

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author janjonas

    @janjonas

    Could you post the comment in IE8 when the WP-Ajaxify-Comments plugin is disabled?

    Well, it’s strange – but after clicking it once and getting the error: if I click again then it goes through just fine.

    -David

    Plugin Author janjonas

    @janjonas

    Does it work for the first click, when the plugin is disabled?

    Could you also try to disable the WYSIWYG editor if this feature is hard-coded in the theme. Just to find out, what is the cause for the problem…

    I just tried deactivating the plugin and it did submit the comment correctly in IE 8 but put the comment in a moderation status.

    I also tried deactivating the WYSIWYG for comments plugin while keeping your plugin active and it went through just fine without the error.

    So, it seems as though the system isn’t recognizing that the comment in the WYSIWYG is there while using your plugin? Any thoughts as to how to fix that?

    Thanks so much for the super fast replies!

    -David

    Plugin Author janjonas

    @janjonas

    Hi,

    please try to set the ‘OnBeforeSubmitComment’ callback on the plugin’s settings page to:

    document.getElementById("comment").value = tinyMCE.getInstanceById("comment").getContent();

    Hope this helps…

    You are a genius! It worked! Thank you so much!!! 🙂

    Plugin Author janjonas

    @janjonas

    Thanks for your feedback.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Error "Please type a comment" on IE 8 w/ comment added already’ is closed to new replies.
Skip to toolbar