Support » Plugin: Social Media Share Buttons Popup & Pop Up Social Sharing Icons » Error : Please fix your theme to make plugins work correctly

  • Resolved PG

    (@pacificim)


    This plugin causes the following 2 error messages to appear when activated with the theme X. See https://theme.co/. According to the theme support this is due to the way your plugin has been coded that is causing this issue. Please fix this issue in your next plugin release.

    Error : Please fix your theme to make plugins work correctly: Go to the Theme Editor and insert <?php wp_head(); ?> just before the </head> line of your theme’s header.php file.

    Error : Please fix your theme to make plugins work correctly: Go to the Theme Editor and insert <?php wp_footer(); ?> as the first line of your theme’s footer.php file.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support alexsev

    (@alexsev)

    Thanks for reaching out! That is a theme issue. According to WP standards, those codes need to be included in the theme. If they are not, the theme creator has to include them in a way that doesn’t break his theme.

    Thread Starter PG

    (@pacificim)

    Response from theme developer: Please be informed that we have a different templating system that still follows the WordPress standards. You cannot find wp_head() or wp_footer() in the header.php or footer.php because we use stacks. Those functions were added in the other header files. Please ignore these error messages. The plugin should work with no issues.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.