Support » Plugin: Dynamics 365 Integration » Error – “Please fill in the fields that are marked as required *”

  • Hello There,

    I have set up a test site to run a trial integration before confirming some work for a client.

    When I click to connect using the CRM Online & URL/Password method, I am receiving a “Please fill in the fields that are marked *”, but I have populated the URL, User, and Password fields, and there doesn’t appear to be any more fields, and none are marked with a *.

    I’ve had a scan through the support threads and I cant see this issue – Is this something you can help with? Am I missing something?

    The site I’m using is on by localhost – would that make a difference? I have the TwentyTwentyOne Theme active, and no other plugins. WordPress version 5.8.2. Neither of the STS / Cert. errors checkboxes are checked in the settings, and I have selected CRM Online.

    Appreciate your help, thanks

    Rob

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author alexacrm

    (@alexacrm)

    Hi Rob,

    looks like we might have a small bug related to the new OAuth authentication settings. Try this: select OAuth 2.0/Shared Secret radio button, fill in app id and secret with anything (does not have to be correct), press connect (you will receive an error). Now switch back to username/password auth and complete the fields – you should be able to connect now.

    Note: we do recommend using OAuth 2.0 moving forward.

    Thanks
    George

    Thread Starter robwhitaker1

    (@robwhitaker1)

    Hi George, thanks for your prompt response.

    I can confirm that this bypasses the error above. I am however receiving a different message – “Unable to connect to Dynamics 365: Argument 1 passed to DOMDocument::importNode() must be an instance of DOMNode, null given.”

    Are you able to offer any suggestions based on the above error?

    I’ve had another looks through the docs and the support forum, I can’t see a reference this message anywhere else.

    Your help is much appreciated,

    Rob

    Plugin Author alexacrm

    (@alexacrm)

    Rob,

    set logging level to Debug on About tab, reproduce the problem, download the logs from About tab and send them to support@alexacrm.com. Also include a screenshot of your plugin configuration screen.

    Thanks
    George

    Plugin Author alexacrm

    (@alexacrm)

    Just did a quick check. Usually we see this error when a hosting server/environment blocks communications with Dynamics 365/CRM instance. Please check that you don’t have any firewall in place that could be blocking the outbound comms.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.