• Resolved JohnP

    (@johnp)


    Since 27th December, attempts by non-logged-in visitors to submit a comment have begun producing a pop-up with the following message:

    Error: Please fill in the correct answer to the security question!
    [Go Back]

    Users can comment successfully if logged in, but others get the error message.

    The “Protect blog comments” checkbox is unticked – I only use this plugin for user registration.

    My current update is No-Bot Registration Version 1.8.1

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Arnan de Gans

    (@adegans)

    Both logged in comments and non-logged in comments work fine for me with version 1.8.1

    What screen are you on exactly?
    What settings do you use for No-Bot Registration?

    Thread Starter JohnP

    (@johnp)

    You are welcome to try and make a comment on the site in question and see for yourself.

    I don’t understand your question “what screen”. The error appears when a non logged-in visitor clicks the button to submit a comment.

    The only setting I have checked is “Protect user registration”.

    The site has not been modified for a couple of years, so the plugin update is the only change.

    Plugin Author Arnan de Gans

    (@adegans)

    There is no security field on your comment form. Please check your settings.

    Thread Starter JohnP

    (@johnp)

    I’ve never used a security field on the comment form.

    This plugin has been doing a great job of stopping bot registrations – I don’t need any comment protection.

    Screenshot of settings:

    Plugin Author Arnan de Gans

    (@adegans)

    Version 1.8.2 should fix the issue.

    Available through updates soon, or here as a free download – https://ajdg.solutions/product/no-bot-registration/

    Thread Starter JohnP

    (@johnp)

    Thank you for your prompt response Arnan. My issue is fixed with the 1.8.2 update.

    Sorry about the double post, I noticed the thread I jumped on had been marked “resolved” and thought you might not see it.

    I’m removing the screenshot of my settings, in case bots learn to read.

    Plugin Author Arnan de Gans

    (@adegans)

    Excellent 🥳

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error: Please fill in the correct answer to the security question!’ is closed to new replies.