Support » Plugin: WPC Composite Products for WooCommerce » Error: Please choose a purchasable product for the componet ….

  • Hello,

    I noticed that I get the error: Please choose a purchasable product for the componet **product** before adding this composite to the cart.
    https://ibb.co/9tjQ0SF

    My composites are made of variable products and all are always in stock.
    # Manage stock? Yes
    # Allow back orders? Allow

    Your plugin does not see the variations anymore because it things they are out of stock or something?

    I had to downgrade your plugin to version 4.2.0 for it to work again.
    So somewhere in your updates it stops function in my 4 shops.

    Can you help me fix this?

    • This topic was modified 6 months, 1 week ago by SLV.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support miemie

    (@miemie)

    Hi @dwnl,

    Can you pls kindly send us the public product link for us to check and help you?

    Regards,

    Thread Starter SLV

    (@dwnl)

    I do not want this link to be public…

    Plugin Support miemie

    (@miemie)

    Hi @dwnl,

    I checked our demo site of WPC Composite product but there is no issue as you mentioned. You can check demo sites in the below link.
    https://demo.wpclever.net/wooco/

    There might be an incompatibility with your theme and other plugins

    In order to check if this is an issue triggered by another plugin or from inside our plugin, please follow my below instructions. I need to make sure that our plugin is functional with the basic WooCommerce & theme on your site or not.

    – Create a full backup of your site and keep it in a safe place.

    – Updates all current active plugins on your site to the latest versions, and so do WooCommerce and WordPress, too.

    – Switch the theme on your site to the WPClever theme.

    – Deactivate all other plugins, except for WooCommerce & our plugin.

    – Check the front-end behavior.

    Please follow these steps. If after taking these steps and our plugin is working again, then it’s another plugin or theme on your site that has caused this, you can find that out by deactivating plugins one by one to find the culprit.

    Best regards.

    Thread Starter SLV

    (@dwnl)

    I did all of that, but the problem keeps existing.
    I have contacted you via your ticket system, but you do not help. It’s now 1,5 month and no help.
    Not good! I left you a bad review, you left me no choice.

    • This reply was modified 4 months, 3 weeks ago by SLV.
    • This reply was modified 4 months, 3 weeks ago by SLV.
    • This reply was modified 4 months, 3 weeks ago by SLV.
    Thread Starter SLV

    (@dwnl)

    ​And another month has gone by and no answer and no fix…

    Thread Starter SLV

    (@dwnl)

    So I found what the problem is.

    In the previous version, I could add a variable product. This does not function any longer in your new version.
    I now need to add ALL the variation from that variable product manually into the smart composite product made with your plugin.

    Please make this function work again.

    Thread Starter SLV

    (@dwnl)

    Hello? some help here?

    • This reply was modified 3 weeks, 3 days ago by SLV.
    • This reply was modified 3 weeks, 3 days ago by SLV.
    Thread Starter SLV

    (@dwnl)

    Hello?

    Thread Starter SLV

    (@dwnl)

    ​Hello? Why don’t you help?

    Thread Starter SLV

    (@dwnl)

    Great support!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.