Support » Plugin: Edwiser Bridge - WordPress Moodle LMS Integration » Error “Please check Moodle URL !” – but the URL is correct

  • Resolved OneHundred

    (@onehundred)


    Hello. I’ve sent a few emails, but no reply yet.

    I’m trying to test the connection (the first step), and it keeps saying “Please check Moodle URL !”. The URL is correct. I’ve tried with and without http/https, I’ve also tried with and without the trailing slash.

    I have two domains (let’s say abc.com and xyz.com) with WordPress installed, and Moodle on /lms/.

    abc.com pointing to abc.com/lms/ doesn’t work, I get the error code.
    abc.com pointing to xyz.com/lms/ works fine.
    xyz.com pointing to abc.com/lms/ also works fine. So the URL, WP, Moodle/ Tokens all work, but I can’t get abc.com to point to abc.com/lms/.

    Please help.

    I’m keen to buy the bundle and set it up this week, but I can’t get passed the first (free) step.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author WisdmLabs

    (@wisdmlabs)

    Hi @onehundred

    Please check if the self request are not blocked on your server ?

    Also, check if the abc.com server is able to find out/locate the abc.com
    It might happen that on the abc.com the requests are blocked to self-domain using htaccess file.

    To Check this create a test.php file on abc.com server and send the curl request to that domain.

    The code for the same is as follows:

    $url = 'http://abc.com/';
    $useragent = 'Opera/9.80 (J2ME/MIDP; Opera Mini/4.2.14912/870; U; id) Presto/2.4.15';
    $ch = curl_init('');
    curl_setopt($ch, CURLOPT_URL, $url);
    curl_setopt($ch, CURLOPT_USERAGENT, $useragent); // set user agent
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
    curl_setopt($ch, CURLOPT_FOLLOWLOCATION, true);
    echo $output = curl_exec($ch);
    curl_close($ch);
    echo $contents;
    $url="http://abc.com/lms"

    Add the above code in test.php and check it’s output. If it shows abc.com/lms Homepage then please contact us so that we can check the issue at your end.

    Thank you. I’ve had a reply via email too, and you/they are going to look at my website.

    Hello, I have the same problem.

    WordPress: http://vps536028.ovh.net/
    Moodle: http://vps536028.ovh.net/acceso-examen/

    I have tried your code: http://vps536028.ovh.net/test.php
    But we have the website in maintenance mode.

    We haven’t redirected the domain yet, can that be the problem?

    Thank you very much.

    Solved!

    vinay

    (@paudelvinay)

    Hi @binfor
    I am having the same/similar problem on one of my site.
    please let me know how did you solve it?
    Thank you.

    • This reply was modified 2 years, 3 months ago by vinay.

    Hello,
    We change the url to the main domain.

    And we were using https, we had to indicate that in config.php:
    $CFG->wwwwroot =’https://domain.com’;

    I hope you can work it out.
    Greetings

    @binford . Could it possible to speak spanish with you about that problem ?

    Thanks

    vinay

    (@paudelvinay)

    Hi @binford
    Thank you for the reply.
    I have used the same configuration/setting as you have mentioned, but it still doesn’t work.
    Thank you.

    Buenos días,

    Lo siento, no recuerdo exactamente cómo resolvimos el problema porque dimos muchas vueltas y tocamos muchas cosas.

    Cambiamos la url al dominio principal con https y seguimos todas las instrucciones de instalación del módulo tanto en WordPress como en Moodle: https://edwiser.org/bridge/documentation/

    Espero que lo podáis solucionar.
    Un saludo.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error “Please check Moodle URL !” – but the URL is correct’ is closed to new replies.