Support » Plugin: WC-AC Hook » Error: PHP Strict Standards

  • Resolved jenrosario13

    (@jenrosario13)


    Hi. I’m getting this error with your plugin:

    PHP Strict Standards: Only variables should be passed by reference in /var/www/html/run/wp-content/plugins/wc-ac-hook/wc-ac-hook.php on line 105

    Might be a bug in the code?

    reference:
    $last_default_tag = end(explode(‘,’,$default_tags));

    http://stackoverflow.com/a/33127737

    Thanks for the help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author mtreherne

    (@mtreherne)

    Thank you. It is an error with respect to coding standards. The parameter to the end function should be an array not a function returning an array. It appears that it still works (functionally), but a warning will be reported if you have E_STRICT set for your PHP install. I will correct the code in due course.

    Got it. Thanks so much for the quick response!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Error: PHP Strict Standards’ is closed to new replies.