Support » Installing WordPress » Error: PHP is not running

  • Hi there,
    I have installed WordPress3.0 on my webspace by following the ‘5-minute instructions” in detail. When entering ‘wp-admin/install.php’ into the Browser there’s an error coming up: “PHP is not running. WordPress requires that your server is running PHP. Your server does not have PHP installed or PHP is turned off.” This is quite strange as I have reconfirmed with my host ( that my webspace is running with PHP5. The host also mentioned that the files should have “.php5” as endings in order to make them readable by the PHP5-Parser. I have no clue what that means. And, it does not seem that any of the wordpress files have such endings. Also, the host suggested adding a file “.htaccess” next to those two files “AddType x-mapp-php5 .php” and “AddHandler x-mapp-php5 .php2“. Again I have not the faintest idea what that means and how this could be done. I have not seen any wordpress files under those names. Besides wordpress there is nothing downloaded on my webspace.
    Is there anyone who could assist me with troubleshooting in order to get the wordpress3.0 running? If any further questions please let me know. However please note that I am just a user and have no experience at all in hosting, creating homepages and all these nice things. Many thanks in advance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Sounds like you need to create a .htaccess file in your web-root folder and add those two line suggested. Use the file manager that 1and1 offers to create and edit the file.

    Thread Starter Leylanet2010


    Thanks. I have created a .txt file, named it .htaccess, entered the two lines and saved it in my webspace on the very top of the tree. No improvement. Still the same error.

    Time to call 1and1, again! If you want to leave WordPress out of the equation, then use the script in Finding_Server_Info — that’s a very small PHP script to test with.

    I had a similar problem and it was involved with setting up the database & wp-config file properly. Go to your database through your sites main control page – find the section that controls your database (phpmysql ?).
    Open your wordpress database and check the permissions on it and make sure you have a user set up, have global permissions set, set a new password (and write it down) and save. Go to your wp-config.php file and edit it to reflect the proper database settings i.e. your user name, and password. Save, and try again. I am not an expert and can’t take you through step by step, you will have to look at some of the good tutorials on the web too. Better tutorials on the web than on WordPress – search for the indivdual topics you need, check to set up database on your hosts help section or the name of the database, setting up a wordpress site etc. Good luck

    I have the same problem but on local server.
    i have installed WAMPSERVER which can support php 5.2.6
    when i run install.php on my browser it show me the following error (Error: PHP is not running)
    Please suggest me what should i do.
    Any suggest will be appreciated.

    Moderator James Huff


    Volunteer Moderator

    Kakar, you should contact the WAMP forum about that:

    I faced the same problem using MAMP. Only when I edited the preferences and set the “Start page URL” to “/” instead of “/MAMP/” did it work.

    A special note of thanks to the member: nauvidi !!!

    I am using MAMP as well, and had encountered the same error with “PHP not running” as you described. As soon as I changed the “Start Page URL” to “/” instead of “/MAMP/” everything worked fine.

    I had spent the better part of a day chasing this error until I discovered your post.

    Thank you!

    goodday everyone!,

    Im unexperienced user of mysql, first time uploading wpblog withing my site. imnot pretty sure but i think ihave Wamp. In my server (zymic) php suppossed to be on, but i dnt know why i still have the same problem as kakar. idont really know what “Start Page URL” means :/ but as you guys have told that your using mamp, i dont know if that would be the same problem as me.

    is still there any solution then ? i’d really appreciate any kind of help.

    thanks ! 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error: PHP is not running’ is closed to new replies.