Support » Plugin: Page scroll to id » Error page when saving changes in admin with Litespeed Web Server

  • I get a “403 Forbidden – Access to this resource on the server is denied! (Proudly powered by LiteSpeed Web Server)” page when I click “Save Changes” within the WordPress Admin tools. The link goes from “/wp-admin/options-general.php?page=page-scroll-to-id” (before saving) to “/wp-admin/options.php” (The Error Page).

    The plugin works fine on the frontend but I want to add an offset to allow for the sticky header menu. I have tried disabling all the other plugins, resetting the permalinks and switch to a default WordPress theme but I get the same error after taking these steps. All admin pages for other plugins installed work fine as an aside.

    I don’t have the WP LiteSpeed plugin installed and when checking CPanel, LiteSpeed appears to be off so this may be activated a level above CPanel and out of my control.

    Any suggestions on how to fix this?

    thanks in advance!

    Simon

    • This topic was modified 2 years, 3 months ago by ubiquedesign.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author malihu

    (@malihu)

    Hello,

    I can’t really say how to fix this as haven’t had any similar requests before. Do other plugins work on the back-end? Did you install “Page scroll to id” via wp admin interface or FTP?

    Did you try deactivating/uninstalling “Page scroll to id” and install/activate it again?

    malagraphicdesign

    (@malagraphicdesign)

    Hello,
    I installed the page scroll to id plugin yesterday, and I am also having this error. (When I change settings via the wordpress admin tools I get 403
    Forbidden Access to this resource on the server is denied!)
    I don’t get this with any other plugin settings. Any ideas?
    Thanks,
    Mary Ann Lawrence
    lawrencegraphicdesign.com

    Plugin Author malihu

    (@malihu)

    @malagraphicdesign Hello,

    Does your server have the “mod_security” feature (is it turned on)?
    Sometimes this feature may give a false positive when saving plugin settings, posts, pages etc.

    Do you have access to your server logs in order to see details about the 403 error?

    Also, can you check the permissions of plugin’s folder (“page-scroll-to-id”)?

    Maybe the issue can be fixed by simply re-installing the plugin.

    Can you contact your hosting support in case the issue comes from “mod_security” feature?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error page when saving changes in admin with Litespeed Web Server’ is closed to new replies.