WordPress.org

Support

Support » Plugins and Hacks » Plugin Organizer » [Resolved] Error: order values were the same

[Resolved] Error: order values were the same

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Jeff Sterup

    @foomagoo

    Plugin Organizer doesn’t create a pop up that says “order values were the same”. Did you mean “The order values were not unique so no changes were made.”? If so that is a problem I’ve seen with multi site where a plugin is network activated and it throws the count off so that the order of plugins that is trying to be saved doesn’t contain all of your plugins. This is to prevent the plugin from deactivating any plugins. I’ve been meaning to fix that but havent gotten to it. I will start working on a solution soon. If this is not the error message you are seeing please give me a better explanation so I can understand the problem.

    Hi Jeff, thanks for your reply, this was indeed the error message i received. Problem is that on removing, reinstalling and activating again this message still pops up, probably because of information still left on server? I’ll be looking out for the update!

    Man I really love this plugin though, traditionally the last fix when creating a website always makes me happy to see the extra time saved in loading! So thank you,

    Nick

    Plugin Author Jeff Sterup

    @foomagoo

    I think the problem comes from a plugin being activated on one of your sites and then being network activated on top of that. This leaves the plugin in the local sites option for active plugins but doesn’t display a row for that plugin on the plugins page because it is network activated. Then you have a mismatched number of plugins that are being submitted when you order them. If you can, try deactivating your network plugins and then deactivate them on the networked site if they are still active. Then go back and network active them. This should remove the network activated plugin from the local active plugins option. Hope that makes sense. I’ve been working on a change to the plugin that will show you the network activated plugins that also appear in the local active plugins so you can still re-order them even if this happens. I will hopefully be able to release it this week.

    Thanks Jeff!

    By the way you are totally right: I network activated the plugin and because I could not find any way to globally cofigure it I activated it again on one of the websites. Some of the network activated plugins don’t remember settings after deactivating so I think I will wait for your update.

    Plugin Author Jeff Sterup

    @foomagoo

    Update to version 2.5. I added functionality to fix the issue as well as adding the ability to disable network activated plugins. That was missing before. Let me know if the new version fixes your issue.

    Hi Jeff, works perfectly thank you!

    Plugin Author Jeff Sterup

    @foomagoo

    NP. Thank you for pointing out the issue so I could fix it. If you like the plugin please give it a star rating on the plugin page.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Error: order values were the same’ is closed to new replies.
Skip to toolbar