Support » Plugin: Progressive WordPress (PWA) » Error onesignal in multisite

  • Resolved josimarcsilva

    (@josimarcsilva)



    Hello!

    Your plugin has a bug.
    I use the official onesignal plugin on a multisite network.
    Everything was working fine but when I activated your active network plugin my the main network site stopped working.

    Please, look at this for us.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Nico Martin

    (@nico_martin)

    Hi @josimarcsilva

    Thank you very much for your valuable feedback.
    I found the bug and I was also able to solve it with version 2.1.2.

    Progressive WordPress detects if the OneSignal WordPress Plugin is active and uses their push messaging functionalities instead. Unfortunately this did not work when the plugin was network activated. Now, it should work as expected.

    Kind regards,
    Nico

    josimarcsilva

    (@josimarcsilva)

    Thank you!

    Before you upgrade I activated site by site (not active network) and it worked too.
    But with the upgrade now it will get better!

    Thanks for the excellent support!

    josimarcsilva

    (@josimarcsilva)

    Hello!

    I tested the new version. But you have the same problem.
    When your plugin is activated as active network in multisite it becomes incompatible with onesignal.

    It works in both cases below:

    1) Onesignal enabled site by site (not network active) with your PWA plugin also site by site is running normally.

    2) Onesignal active network with its PWA plugin also active network is working normally.

    3) Onesignal active network with its PWA plug-in enabled site by site (not active network) is working normally.

    It is not working in the case below:

    4) Onesignal enabled site by site (not active network) with its PWA active network plugin in multisite is not working. Throws the whole site down.

    Whoever works with wordpress multisite usually, for business reasons, needs to work with some active network plugins and other site by site. So it is important your plugin to work in all cases mentioned above.

    I think it’s going to be easy for you to identify the problem now.

    Kind regards,
    Josimar Cordeiro

    Plugin Author Nico Martin

    (@nico_martin)

    Hi Josimar

    Yes, You’re right. And again I found the bug. The solution will come with the next update (problably in a few hours).

    Kind regards,
    Nico

    Plugin Author Nico Martin

    (@nico_martin)

    Hi Josimar

    I will close this issue since I did not get any feedback.

    Kind regards,
    Nico

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.