Support » Plugin: ZodiacPress » Error on ZodiacPress

  • Hi,
    I have installed this and gone through all presupport checks.
    As it is a live site, I could not disable plugins so installed it on a test subdomain, http://test.biteymcchomp.com/ with no plugins apart from ZodiacPress and the standard 2012 theme. This is still giving the same error. After inputting in the details, following the UTC step, it displays ‘Something went wrong’
    System info on test site

    ### Begin System Info ###
    
    -- Server Info
    
    Server Software:          Apache
    PHP Version:              5.5.38
    GD Support:               Yes
    PHP_SHLIB_SUFFIX:         so
    exec() Function:          Enabled
    chmod() Function:         Enabled
    
    -- ZodiacPress Info
    
    swetest file:             Okay
    Ephemeris permissions:    Executable
    
    -- WordPress Info
    
    WP Version:               4.9.4
    Multisite:                No
    WP_DEBUG:                 Disabled
    WP Memory Limit:          40M
    
    -- Theme
    
    Theme Name:               Twenty Seventeen
    Theme Version:            1.4
    Is Child Theme:           No
    
    -- Active Plugins
    
    ZodiacPress by Isabel Castillo, Cosmic Plugins version 1.7
    
    ### End System Info ###	

    Main site info

    ### Begin System Info ###
    
    -- Server Info
    
    Server Software:          Apache
    PHP Version:              5.5.38
    GD Support:               Yes
    PHP_SHLIB_SUFFIX:         so
    exec() Function:          Enabled
    chmod() Function:         Enabled
    
    -- ZodiacPress Info
    
    swetest file:             Okay
    Ephemeris permissions:    Executable
    
    -- WordPress Info
    
    WP Version:               4.9.4
    Multisite:                No
    WP_DEBUG:                 Disabled
    WP Memory Limit:          40M
    
    -- Theme
    
    Theme Name:               Enfold
    Theme Version:            4.2
    Is Child Theme:           No
    
    -- Active Plugins
    
    Counter Number Showcase by wpshopmart version 1.0.5,
    Current Planetary Positions by Isabel Castillo version 2.1.1,
    Daily Moon Forecast by Isabel Castillo version 2.1.1,
    HubSpot Tracking Code for WordPress by HubSpot version 1.2.1,
    HubSpot - Free Marketing Plugin for WordPress by HubSpot version 6.1.4,
    Moon Phases by Joe's Web Tools version 3.1.1,
    Service Box by wpshopmart version 1.2.3,
    Super Testimonial by Themepoints version 1.4,
    Team Members by WP Darko version 3.0.1,
    WooCommerce Variable Product Description by Shop Plugins version 1.0.1,
    WooCommerce by Automattic version 3.3.4,
    YITH WooCommerce Wishlist by YITHEMES version 2.2.1,
    ZodiacPress by Isabel Castillo, Cosmic Plugins version 1.7,
    ZodiacPress Windows Server by Isabel Castillo version 1.2.1
    
    ### End System Info ###	
    • This topic was modified 7 months, 4 weeks ago by  calann.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author isabel104

    (@isabel104)

    Thank you for the info and for putting up a test site. I tried both of your pages and got the same error.

    The plugins shouldn’t be the issue since the error also happens on your test site without other plugins.

    1. You have two of my other plugins installed: Current Planetary Positions, and Daily Moon Forecast. Can you confirm that those work on your site? If they do work, then please disregard number 2 (the next point). In this case, please let me know.
    2. If the plugins in number 1 don’t work: This error means that something is not allowing the Ephemeris file to execute. I see that your system info says that your Ephemeris permission is fine (Ephemeris permissions:Executable), but I am going to guess that something on your hosting account is overriding this and blocking permission.

      (Technical Details: The reason that I’m guessing this is because your PHP version is 5.5.38, which is an outdated, unsupported version that has reached its “End of Life.” This plugin technically still supports as low as PHP version 5.4, but I am going to change that to 5.6 very soon because outdated PHP version may expose sites to security vulnerabilities. So, if your hosting company is allowing your site to run on an insecure and outdated PHP version, it is possible that they also have some measure in place that is blocking the executable Ephemeris file. This is a harmless file, but they may be afraid of all executable files.)

      If you wouldn’t mind telling me which hosting company you use, and which hosting plan, I could investigate further to see if they do block executable files.

    Hi Isabel,

    The two other plugins don’t work either so I believe you are correct with option 2. My hosting account is run by 34SP and I am using their reseller plan.

    Just as an update, I have updated both sites to PHP 7.1 and spoke to my host service. They claim to not block any files unless they are known as potentially malicious.
    All three plug ins are still not working. As they are working for others, it does seem like an issue with my hosting.
    It’s a shame as it looks like an amazing plugin 🙂

    I was having a lot of problems with the ephemeris exec() function. I changed my hosting server and it worked.
    This new hosting service is awesome, you should try it.
    Click here to access the hosting that works with ZodiacPress

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.