WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Error on upgrade to Connections 7.5.1

[Resolved] Error on upgrade to Connections 7.5.1

  • Ruanna
    Participant

    @ruanna

    Upgrading to 7.4.1 went fine, but with the new version (7.5.1) I get the following error:

    Fatal error: Class ‘cnRole’ not found in /home/visit/public_html/wp-content/plugins/connections/connections.php on line 461

    And so I’ve reverted back to 7.4.1.

    I’m running Connections on a subsite of a multisite, using the Market template.

    Thanks!

    http://wordpress.org/extend/plugins/connections/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    Can you explain the process that you used to upgrade? So far this seems to affect .1%, yep, point one percent of upgrades. Not sure why …

    Just delete the plugin and re-install it and it’ll be fine.

    Ruanna
    Participant

    @ruanna

    Hi…

    1) First time I auto-updated, and got the error.
    2) So I used Easy Theme & Plugin Updater to restore back to 7.4.1.
    3) Then (just for fun) I used Easy Theme & Plugin Updater to try to go back to 7.5.1 and got the same error.
    4) And so I repeated step 2 to get back to 7.4.1.

    Today, however, I (as you instructed) deleted 7.4.1 and re-installed 7.5.1 and now I’m good!

    (In case it helps you get to the bottom of the .1%) I’m also running ROT13 and Connections Widgets.

    Thanks for the support! Ruanna

    Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    Did you have the error on the latest update?

    Ruanna
    Participant

    @ruanna

    At first I couldn’t download the plugin (connection time-out – go figure!) so I auto-updated and got this:

    “Fatal error: Class ‘cnRole’ not found in /home/visit/public_html/wp-content/plugins/connections/connections.php on line 489”

    So I restored back to Connections 7.5.1.

    I returned to the repository and this time I was able to get the download – tried to update again using Easy Theme & Plugin Updater. Now I’ve got a page that says “Template Not Found.” (http://www.sierracountynewmexico.info/shopping/a-z/)

    In the past the template (Market) has been stored outside the plugin directory – in wp-content – do I need to move it elsewhere? Let me know, if I don’t hear from you soon I’ll probably go back to 7.5.1.

    Thanks for the heads up on the update!

    Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    What the exact shortcode you’re using? You have the list_type option set, yes?

    Ruanna
    Participant

    @ruanna

    Nnnnnoooooo…….

    [connections]

    Is my shortcode. Do I need to start reading the instructions? 😉

    Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    That’s really odd! Are the files for the template is in this path:
    ../wp-content/connections_templates/market

    Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    Oh, and Market is showing as activate?

    Ruanna
    Participant

    @ruanna

    That’s the path…but when I check to see what template I’m using via the plugin, I’m seeing “Template market can not be found.”

    I was thinking I’d try uploading it again using Install (to see what happens)but I’m having trouble finding the original download. I’ll keep hunting.

    Ruanna
    Participant

    @ruanna

    Market isn’t in my purchase history on your site, either. I’m flummoxed.

    Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    Can you send me your email address using the contact form at the bottom of the page on my site — to look-up your purchase.

    Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    I just resent you the details.

    Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    Any chance for a temp admin account, so I can take a look?

    Ruanna
    Participant

    @ruanna

    Okay to send tend temp admin info to the email I just received?

    Plugin Author shazahm1
    Participant

    @shazahm1hotmailcom

    @ruanna

    Yep.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Error on upgrade to Connections 7.5.1’ is closed to new replies.