Support » Plugin: IP Geo Block » Error on updating 3.0.4

  • ResolvedPlugin Author tokkonopapa

    (@tokkonopapa)


    Dear all,

    You might see the following message on dashboard when you update to 3.0.4:

    IP Geo Block: /homepage/blog/test/wp-content/plugins/ip-geo-block/classes/class-ip-geo-block-logs.php (685) Unknown column 'asn' in 'field list'

    This is fetched by this plugin itself.

    Please once deactivate and activate again. Then the error will be gone.

    Sorry for the inconvenience.
    Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • YEs, thanks

    Alex

    I got this too. Exactly the same line and error. Please let me know when it’s good, thanks! XO!

    ALSO, if you guys create a block by country add-on for this plugin I would LOVE IT!!!

    Yes, works than after that.
    Brilliant work!
    I will say thank you verry much for this absolut usefull plugin!!

    I hav one question, I must update a lot of WordPress Sites with this plugin, so I have to go manualy in all WordPress sites and must do this by hand. I make thge updates with Infinite, so I did must go into every page for such updates.

    Do you think I (should) can wait for the next minor update or must I do this also in the future once a time at any WordPress Site if I havent deactivate and activate this plugin?

    Kimd regards

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear all,

    Thank you for the patience.

    I’ve fixed another issue that was reported by @alexlii in this topic.

    I’m now dedicating to test in my real site and may be able to release subsequently or soon afterward.

    @celestial-petals, How about IP Geo Allow ? You can utilize the hostname of your ISP for the whitelist. It makes admin screens strictly private with more flexible way than specifying IP addresses even when your IP address is assigned dynamically. If you have any questions about this extension, please open a new topic.

    @hai3009, if you don’t have the similar issue in this topic, you can keep using 3.0.4 after you once deactivate and activate again.

    Milestone:

    • 3.0.5: WP-ZEP for plugins/themes area on Nginx.
    • 3.0.6: Network wide settings in multisite.

    Again, thank you for everyone!

    • This reply was modified 1 year, 9 months ago by  tokkonopapa.

    Thank you. That took care of it.

    Hello,

    utilize the hostname of your ISP for the whitelist?

    Do you mean domain name?

    Thanks

    Alex

    Plugin Author tokkonopapa

    (@tokkonopapa)

    @alexlii, you’re right!

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear all,

    This issue was fixed in 3.0.4.1.

    I’d like to thank you all!

    thanks.

    If domain name is prior choice, should we input “http://” ? Or just input

    Ourdomain.com

    ?

    Appreciated with your work!

    Alex

    • This reply was modified 1 year, 9 months ago by  alexlii.
    • This reply was modified 1 year, 9 months ago by  alexlii.
    • This reply was modified 1 year, 9 months ago by  alexlii.
    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Alex,

    If domain name is prior choice, should we input “http://” ? Or just input

    Without “scheme”. Just “example.com” for example.

    Please see README.md at https://github.com/ddur/WordPress-IP-Geo-Allow

    And if you “Save Changes”, then all name in the list will be validated. So you can find if the names are OK or not.

    Please try!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Error on updating 3.0.4’ is closed to new replies.