Support » Plugin: WooCommerce » Error on trying to add variable product to cart

  • Resolved Milan.Nikolic

    (@milannikolic)


    Hi,

    When I try to add a variable product to cart, I receive this:
    Please select some product options before adding this product to your cart.

    I have tried to change to default WP theme and to disable all plugins, nothing helps, it still doesn’t work.

    This is a really urgent thing, so I would appreciate any help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Hi @milannikolic,

    Do you have a URL to a product so we can take a look?

    Here it is for instance: https://powermetercity.com/product/4iiii-precision-power-meter-for-shimano-105-5800/ote that on some ocassions it might work, but if you continue shoppimg, you will se it is not working.

    Hi Thomas. I work with Milan (he is my developer but has intermittent internet access right now as he is traveling so hopefully I can help a bit).

    It is all of our variable products. Here is an example:

    https://powermetercity.com/product/4iiii-precision-power-meter-for-shimano-105-5800/

    You select an option, click ADD TO CART, and it says “Please select some product options before adding this product to your cart.” – even though you already did.

    What is very weird, is that it’s impacting some devices and not others. For example, my desktop works fine, but my phone does not. And most importantly, we are getting loads of messages from customers who cannot currently use the store.

    The last thing I would add for the sake of full information…whatever this problem is, it’s also impacting our Instant Search Plug in (box at the top of the page that allows you to search the store). It’s just those two things. Variable products and our Instant Search Plug in.

    Thank you!
    Josh

    Plugin Support yukikatayama

    (@yukikatayama)

    Automattic Happiness Engineer

    Hi @jmatthew01 and @milannikolic,

    I took a look at https://powermetercity.com/product/4iiii-precision-power-meter-for-shimano-105-5800/ and tried adding a variable to cart on different browsers as well as mobile, but so far have not seen the error message to select option before adding to cart. For example on mobile, I was able to go to cart:

    https://cld.wthms.co/ATcOhy
    Link to image: https://cld.wthms.co/ATcOhy

    Is this an intermittent issue, or has it been resolved? If you are still having issues, something to check is if you have a cache plugin, to flush cache, as well have your host clear any server cache.

    Lastly, in regards to the Instant Search Plugin, I’m not 100% what issues you are having with the search but as it is a third party plugin, I’d recommend reaching out to the support team of that plugin.

    Thanks,

    hi,

    This problem seems to be resolved. Basically nothing was done, but it seems that the problem was gone itself.

    Thanks

    Plugin Support yukikatayama

    (@yukikatayama)

    Automattic Happiness Engineer

    Glad to hear it! I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Cheers!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.